2
\$\begingroup\$

I'm currently routing a schematic with Altium (10), it is very small and I use a lot of 'any-angle' traces. Altium can more or less route them 'fine', but the problems really begin when moving traces.

On this schematic I am often dragging and pushing traces, however, whenever I try to drag a traces that connects to an 'any-angle' trace or an 'any-angle' trace itself it will immediately change the 'any-angle' trace to 45 degrees as shown below. Any-angle trace picked up to drag, immediately becomes 45 degree

"Restrict to 90/45" is not enabled, and as I said routing a new trace at any-angle works 'fine'.

| improve this question | | | | |
\$\endgroup\$
  • \$\begingroup\$ This is an excellent question. I don't know of a way to drag an any-angle trace to change the angle. I generally try to stick with 45 degree tracks, personally, but I understand there are some cases where this may not be practical \$\endgroup\$ – DerStrom8 Aug 8 '16 at 13:05
1
\$\begingroup\$

I believe I found the answer. In addition to not having "Restrict to 90/45" checked, you also need to have "Preserve Angle When Dragging" unchecked. This is also in the Preferences --> PCB Editor --> Interactive Routing settings.

enter image description here

| improve this answer | | | | |
\$\endgroup\$
  • \$\begingroup\$ This works, but it has the unfortunate side effect that you no longer push other traces when moving one. Still, it is better than entering coördinates manually or partially deleting traces before dragging them. I will be turning this option on- and off a lot when working with any-angle PCB's. \$\endgroup\$ – valki Aug 9 '16 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.