I built an electronic circuit that uses the Arduino IC (ATmega328P-PU) IC, and the ESP8266. I moved out the IC Circuit from the Arduino Board, and moved it into my own board, so that I could free myself from using the Arduino system, just using the IC.

The system that I am building has 4 water sensors and will trigger a web request when the sensor is triggered.

Everything works OK when I use the 5V and the 3.3V regulator built into the Arduino Board, but when I build my own, the 5V starts to get too hot very quickly. I know that the ESP8266 uses a lot of electricity, but I don't know how to support it with my current regulator setup. Also, usually about 3 seconds into it being powered on using a 12V power supply, it will stop working all together.

Note: I basically did moved my IC Board much like this: https://www.arduino.cc/en/Tutorial/ArduinoToBreadboard

The Parts that I am using are as follows:

Here is my circuits.io, it has the setup and the code: https://circuits.io/circuits/2554003-button-press-wifi-with-esp8266/ enter image description here enter image description here

R1: 10k
R2: 1k
R3: 2k
R3: 220
C1: 100u 20v
C2: 100u 20v

My basic and wiring schema for the ESP8266 setup is like this: http://www.martyncurrey.com/arduino-to-esp8266-serial-commincation/

Again, it works GREAT when the breadboard's power is using the Arduino's built in power regulator.

Also, please note, that I just tried this too, and everything wanted to start burning up just as it would have before: http://electronics-diy.com/3.3v-and-5v-power-supply.php enter image description here enter image description here

My question is: what am I doing wrong?

  • \$\begingroup\$ Is there a schematic diagram available for your setup? You have provided a wiring diagram which doesn't really help us understand the purpose and schema of your system. There seems to be a schematic editor on the circuits.io link on the second button. Most of it's there but all jumbled up. If you can drag the components into a neat layout, take a screenshot and add it to your post you should get a good response. \$\endgroup\$
    – Transistor
    Aug 14, 2016 at 19:27
  • \$\begingroup\$ Yes, thanks, I did just add it. Hope it looks ok. \$\endgroup\$ Aug 14, 2016 at 19:35
  • \$\begingroup\$ Sounds like you have a variety of issues, but even with some of the more acute ones solved, if you are going to power these components from 12v with linear regulators (which are small feedback-controlled space heaters) you may need to heatsink them. A more sophisticated solution would be switching regulator to 5v and then a linear regulator to 3.3v, or eliminating the Arduino entirely in favor of a higher pin count ESP8266. \$\endgroup\$ Aug 14, 2016 at 19:44
  • \$\begingroup\$ Full marks. You should be able to see some of the problems yourself now. See the answers below. +1. \$\endgroup\$
    – Transistor
    Aug 14, 2016 at 19:44
  • \$\begingroup\$ @Bill: Can you clarify what's going on with the schematic edits? My answer was based on your earlier schematic. C1 on the current one is shorted out. \$\endgroup\$
    – Transistor
    Aug 14, 2016 at 19:47

3 Answers 3


You connected your 3.3V regulator wrong.

Its pinout, as seen from the front, is Gnd/Vout/Vin:

LD1117V33-LD33V pinout

You connected it as Vout/Gnd/Vin. Since its Vout is connected to ground, it's likely the regulator is passing its maximum current straight to ground. The same current also has to go through the 5V regulator, which has to drop at least 7V, resulting in a large power dissipation and the regulator getting too hot.

Also, neither your circuit diagram nor your wiring diagram show a ground connection between your power circuit and the rest of your circuit; your esp8266 will never work that way.


enter image description here

Figure 1. A few problems stand out.

Everything becomes much clearer on the schematic.

  1. The GND connection is "powering" U1 while the 3.3 V OUT connection is tied to GND. This isn't going to work well.
  2. There is only one wire from the power circuit to the rest of the circuit so there is no return path to the power supply. You need a link as shown by the green line.
  • \$\begingroup\$ Thanks, I fixed the diagram, I had it incorrect. It is accurate to what I have now. Please take a look at the updated images. My device is still failing the same way. \$\endgroup\$ Aug 14, 2016 at 19:47

You should have some small 0.1uF or 0.22uF caps bypassing both the input and the output of the regulators to ground or they can start to oscillate. If you're drawing more than a few tens of milliamps or so out of the 7805, it is going to get hot without a heat sink. The higher P1 is, the hotter it will get.

  • \$\begingroup\$ I added 100n to both, same issue. :( \$\endgroup\$ Aug 14, 2016 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.