2
\$\begingroup\$

I'm using an Altera MAX 10 chip 10M50SCE144C8G. I want to use its ADC. In datasheet, it says that this chip has a "Single ADC that supports 1 dedicated analog input pin and 8 dual-function pins". However, when I want to use it in Quartus, in the IP parameter Editor, I got an error msg saying that:

Error: unnamed.modular_adc_0: The selected device part number 10M50SCE144C8G does not support ADC.

I tried different versions of Quartus: 15.1 and 16.0, got the same error.

How do I fix this error?

\$\endgroup\$
3
  • 2
    \$\begingroup\$ I honestly think this should be raised with Altera, not with us. \$\endgroup\$ Commented Aug 18, 2016 at 18:51
  • 1
    \$\begingroup\$ Its probably a bug, its amazing that Altera even has as much stuff working as they do because not only do they have to spend time fixing software compiler issues, but hardware compiler issues as well. Is this a Qsys or compiler error? \$\endgroup\$
    – Voltage Spike
    Commented Aug 18, 2016 at 19:42
  • 1
    \$\begingroup\$ To be fair this is not a badly written question and doesn't deserve to be downvoted to oblivion. \$\endgroup\$ Commented Aug 18, 2016 at 20:04

1 Answer 1

1
\$\begingroup\$

That part does not support ADC functionally. Page 4 of the device overview specifically states that SC parts are the compact functionality cores which do not feature ADCs. Only the SA and DA parts have analogue features.

\$\endgroup\$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.