0
\$\begingroup\$

I have to simulate a ideal transmission line and I have drawn the following schematic in LTSpice IV. Circuit

When I run the command to simulate it works but only show a 10V steady value on the output in both start and end of transmission line. I'd like to see the transient values. Can anyone point me what I have done wrong?

\$\endgroup\$
  • \$\begingroup\$ I'm not sure what you expected to happen. You simulated a reactive transmission line with a DC source; the steady state state solution is for there to be 10V on C1. Use a step input, or an AC source if you want something more interesting to happen. \$\endgroup\$ – Brendan Simpson Aug 22 '16 at 15:43
  • \$\begingroup\$ I made a mistake, as pointed out here. I used the wrong voltage source. My bad. But thanks for the tip. \$\endgroup\$ – daniel.franzini Aug 22 '16 at 16:13
3
\$\begingroup\$

You have used a fixed voltage source, which will have 10v output at t=0. LTSpice uses this to initialise the line and capacitor, then the simulation runs.

You need to use a source that starts at zero, then transitions to 10v a little after t=0. A PWL source will do, or the simpler pulse generator.

| improve this answer | |
\$\endgroup\$
  • 1
    \$\begingroup\$ Thank you. I just added a "voltage", chose PWL as function, input t1 = 0, v1 = 0, t2 = 1e-12, v2 = 10V and run it again. It worked perfectly and now I can see the waveforms that (I think) are correct. One thing is that I could not find the "pulse generator". In fact the original circuit had a switch that turned it on at t=0 so what I'm guessing is that I "emulated" this behavior with the PWL. Thanks for the tip. \$\endgroup\$ – daniel.franzini Aug 22 '16 at 16:11
  • \$\begingroup\$ The pulse supply is just another source option, just like PWL is. You can use it to create rectangular waves of varying duty cycles and rise times, as well as single pulses or a finite number of pulses \$\endgroup\$ – Brendan Simpson Aug 22 '16 at 16:18
1
\$\begingroup\$

As others have said you had best use a pulse voltage source rather than a DC source because PSPICE, by default, solves for the steady-state solution before starting the simulation. However if you tell it not to do that, you can get it to work:

enter image description here

enter image description here

Edit:

"Sort of work".

Compare the pulse with 10ns rise time below.

enter image description here

To get the fancier voltage sources, right click on the voltage source, and then click on 'advanced' to get the other options.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.