2
\$\begingroup\$

I have a simple LTC4440-5 circuit in both LTSpice:

enter image description here

(R1 is just a load resistor, which isn't present in reality)

And here in the matrix, there's: enter image description here

And: enter image description here (Note that a few parts are slightly different from simulation to reality: The inductor is a 5uH part, the diodes are both DB2W40300L shottkys, and the mosfet is an AO3400A. However, I can plug any mosfet and any diodes into the simulation and I can't break it.)

I have tried running at both 1mhz, and 100khz input frequency. In LTSpice, everything's peachy; in reality, I get no change from a floating gate.

Now, in the LTSpice simulation, I get this on the boosted gate pin:

enter image description here

And in reality, I get this:

enter image description here

The gate floats at ~3v.

The mosfet seems to be half on, as the TS/inductor pin is at 4v, no load.

I've confirmed that all the rails are as they should be; 5v VCC, 12v on the mosfet, etc. I've tried swapping out 4440s, tested all the diodes, changed input frequency, etc. Nada. I've tried to break the LTSpice simulation to get it to approximate the behavior, but I can't get it to not charge pump.

What have I done wrong?

EDIT: Okay! Now we're getting somewhere. With a 100r resistor as a load in ltspice, I get a nice and stable charge pump. With a 130r resistor in reality, I get a sick 5khz oscillation in the charge pump:

enter image description here (And zoomed) enter image description here

Which... certainly wasn't the behavior I was expecting.

\$\endgroup\$
12
  • 2
    \$\begingroup\$ "R1 is just a load resistor, which isn't present in reality" there you have a pretty important difference \$\endgroup\$
    – PlasmaHH
    Commented Aug 26, 2016 at 14:55
  • \$\begingroup\$ @PlasmaHH Do you think the load would affect the charge pump? I'll try it with a load now... \$\endgroup\$
    – 0xDBFB7
    Commented Aug 26, 2016 at 15:03
  • \$\begingroup\$ "I can't get it to not charge pump" - using logic to reduce this sentence I deduce that you "can get it to charge pump". What's with the incomplete circuit and the INA thing on the PCB. Very confusing. \$\endgroup\$
    – Andy aka
    Commented Aug 26, 2016 at 15:07
  • \$\begingroup\$ @Andyaka The INA thing is a seperate part of the board. I took a terrible screenshot, let me try that again.. \$\endgroup\$
    – 0xDBFB7
    Commented Aug 26, 2016 at 15:09
  • 1
    \$\begingroup\$ @PlasmaHH Well, you're right; load is an issue, though there's definitely something else going on here. \$\endgroup\$
    – 0xDBFB7
    Commented Aug 26, 2016 at 15:47

1 Answer 1

1
\$\begingroup\$

For any wandering over this question in the future; I increased the charge pump cap value and it began running under 250ma load. Switched to a IRS25752, and it worked fine up to about 80% duty cycle, under 100ma load.

I ended up switching to a P-Channel mosfet and forgetting about the charge pump.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.