4
\$\begingroup\$

I have an update. It seems there are multiple posts on Intel's forum by people reporting bricked Compute Sticks even though they were using the factory power supply. I followed the recommendation to reset BIOS by holding the power button for 3 seconds and... it came back to life! That is the third Compute Stick, the one for which I was using the setup with the electronic switch. The previous two are still dead. So, it seems that these computers have some issues with power supply. And the voltage spikes damaged permanently the first two, while after fixing the voltage spike, the last one suffered from corrupted BIOS but it was possible to recover it.


I am using Intel Compute Stick, which basically is a single board computer, and I am experiencing problems powering it from a battery.

Intel Compute Stick

The computer is powered via a Micro USB port. It comes with a wall power supply which has 5V 3A output. I measured the actual output to be 5.16V. The maximum power consumption I measured to be 1A in my application.

Here is what my initial setup was for powering from a battery:

[16V battery] -> [5V 3A out buck converter] -> [Intel Compute Stick]

Using this setup resulted in bricking two computers. Each time, it happened while reconnecting the power supply. I hooked up an oscilloscope and observed voltage spikes when connecting the battery. To cope with this, I decided to add an electronic switch between the buck converter and the computer (Mini MOSFET Slide Switch with Reverse Voltage Protection SV from Pololu) and to make sure it is always open when connecting the battery.

So, my second setup was:

[16V battery] -> [5V 3A out buck converter] -> [MOSFET switch] -> [Intel Compute Stick]

Below are pictures from the oscilloscope, the first two are for the first setup without the switch and the rest is for the second setup. So, it all seemed to look just fine. The actual converter output is around 5.28V which is just slightly more than 5.15V and there are no voltage spikes. At this point I decided to make the final test by connecting the battery and switching the switch on until the initial welcome screen was displayed and then switching back off. I planned to try 200 such cycles, and after 130 cycles Compute Stick died...

enter image description here

So, I still must be doing something wrong, but have no idea what this could be at this point. As far as I can tell, all I have at this point is constant 5V power supply from the converter and I am just opening and closing the switch.

Any ideas?

\$\endgroup\$
  • 1
    \$\begingroup\$ From your edit it sounds like you are trying to fix Intel's problem. Another thought... You said [the fault] "happened while reconnecting the power supply". How can you be sure? Maybe the fault occurs when you power down the stick, and flash memory gets corrupted. You only become aware when you power up the stick. Does the stick have a shut down command to do an orderly shut-down and power off like Windows? Perhaps you should use that? \$\endgroup\$ – Steve G Sep 9 '16 at 8:21
  • 2
    \$\begingroup\$ 'Doctor, every time I pole myself in the eye, I get this pain'. 'Well, stop poking yourself in the eye then!' Powering off a device at the welcome screen sounds like asking for trouble. \$\endgroup\$ – Neil_UK Sep 9 '16 at 8:26
  • 1
    \$\begingroup\$ Not the faintest idea, except that to turn any OS off, except when it's displaying a message 'you can now turn off', is unsafe. \$\endgroup\$ – Neil_UK Sep 9 '16 at 12:06
  • 1
    \$\begingroup\$ Repeating the test 1000's of times with a known well behaved power supply would help distinguish OS related ones from psu glitch ones. || Either a solidly hard clamp at the device power supply input or a low drop out regulator would help prevent spike related deaths. \$\endgroup\$ – Russell McMahon Sep 9 '16 at 13:33
  • 1
    \$\begingroup\$ @TomMises Same advice restated: (1) Test with known solid supply to far more cycles than failure is now occurring at. IF the problem is eg an OS corruption on-board due to improper shutdown this should still happen. (2) Hard voltage clamp at output of your present spsu. This is not an extra LDO but simply a device that ensures voltage cannot rise above some preset limit (3) The LDO is the final suggestion of 3. Any regulator will do but an LDO wastes less power. Devices like LM293x family are targeted at automotive high high noise and spike environment and may suit but should not be needed. \$\endgroup\$ – Russell McMahon Sep 10 '16 at 0:43
1
\$\begingroup\$

It looks like the Intel computer is really sensitive to overvoltage. You could use a two stage power supply for it - a buck converter to drop the voltage down to, for example, 7 volts and then a linear regulator to provide clean and spike-free 5V. The intermediate voltage (7V in my example) should be just slightly higher than the minimal requirement for the linear regulator for best efficiency (though efficiency won't be that great anyway).

I used LM338K to make a car power supply for my Viliv N5 palmtop which has the same problem.

\$\endgroup\$
1
\$\begingroup\$

First graph: is the yellow the battery terminal voltage and the blue the voltage output?

It looks like the battery voltage dips dramatically, presumably due to current spikes. Then the current drops and the converter overshoots its regulation. What is this battery and how long are the leads?

You might be able to improve this by adding a lot of bulk capacitance on both sides of the buck converter, but that gives you other problems (inrush current).

\$\endgroup\$
  • \$\begingroup\$ Correct, the yellow is the battery terminal and the blue is the voltage output. \$\endgroup\$ – Tom Mises Sep 9 '16 at 10:36
  • \$\begingroup\$ The battery is 4S 1000mAh 23C LiPo. The leads were pretty long, however, wouldn't it impact only LC spikes which I captured here? These LC spikes last only a few microseconds and the voltage drops visible in the first graph span several milliseconds. I had tried a 300μF capacitor before the buck converter and it helped with those microsecond spikes, but did nothing to the millisecond drops. The drops did not occur when using a 12V battery, so I was thinking maybe they were due to arcing at the battery connector (due to inrush current I guess). \$\endgroup\$ – Tom Mises Sep 9 '16 at 10:36
  • \$\begingroup\$ Hmm - if they were arcs breaking wouldn't it spike down to zero? Anyway, the important thing to fix is the spiking on the output. \$\endgroup\$ – pjc50 Sep 9 '16 at 11:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.