6
\$\begingroup\$

I want to change all default fonts of Altium to Arial, specifically in the Schematic. Right now they are Times New Roman. I changed my system font in my template but that doesn't seem to effect the components used in the schematics which make up 99% of the text I want to change. I've tried placing new components but it doesn't seem to affect the font's of the Libraries and hence not the fonts of the Ref Des, Part Numbers etc..

On a side note is there a way to change the font off all selected text without changing the size? Any help appreciated.

\$\endgroup\$
  • \$\begingroup\$ I could be wrong but I think you can only change the font (typeface and size) together, not just the typeface. Use Find Similar Objects and FontID Same. \$\endgroup\$ – Spehro Pefhany Sep 13 '16 at 18:32
  • \$\begingroup\$ It is ridiculous that changing the system font is so unnecessarily difficult. \$\endgroup\$ – James Keen Jul 27 '17 at 8:16
2
\$\begingroup\$

You can change the fonts of individual primitives under Preferences > Schematic > Default Primitives. Select each item in the list and click the Edit Values... button.

enter image description here

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ That might work but it is a lot of work to change all of them. Not to mention you have to change the font for Mils and MMs separately. Still hoping there is a global font somewhere. Something must be telling Altium to use Times New Roman... \$\endgroup\$ – ptoupin Sep 14 '16 at 19:56
  • \$\begingroup\$ @ptoupin Consider it as a part of your Altium setup. How much time have you (or your colleagues) spent setting up design templates, design rules, libraries etc? Setting up fonts is trivial compared to all the other stuff. \$\endgroup\$ – Armandas Sep 14 '16 at 20:24
  • \$\begingroup\$ @Armadas I went through the efforct to change all the fonts to Arial. An easier way is to save the default primitives to a .dtf file then find replace all the "Times New Roman" with "Arial". You also have to check the "Override library primitive" on a bunch of the primitives. This did change most of the fonts, however it did not change any of the parameters fonts for components which makes up most of the font on the schematics. Is there a way to change the font of a Library? Or of the parameters of all parts etc.. \$\endgroup\$ – ptoupin Sep 23 '16 at 12:10
  • \$\begingroup\$ @ptoupin I assumed that changing the "parameter" settings would change all the parameter fonts. I gave it a go and it seems that only newly created library components are affected. Unfortunately, I don't know an easy way to change all the existing library components to the new style... \$\endgroup\$ – Armandas Sep 23 '16 at 13:05
  • \$\begingroup\$ Your final statement, "I don't know an easy way to change all the existing library components to the new style", is my frustration. Did you ever find a solution? Where are the most global defaults set and what is the easiest method to change them all? \$\endgroup\$ – JOHN Dec 23 '17 at 0:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.