0
\$\begingroup\$

I am currently panicking slightly because I need PSpice to work properly so I can simulate some diode circuits for my upcoming lab. However, what is happening is that when I try to run the circuit below, PSpice will simulate it once correctly (and show the output graph) with the simulation settings, and then if I change the simulation settings and try to re-run it, PSpice won't open the simulation. Sometimes the simulation fails with an argument error and a can't find error right after. Any help would be greatly appreciated!

This is what I'm trying to simulate: enter image description here

Where Vin is VSIN with 3V amplitude and 1000Hz, no offset. The diode we are using is the D914 (starts with a D, has the number 914 in it). The capacitor is 22uF, and R_L is 5k ohms. When I run simulate this without the capacitor PSpice seems to work correctly, but if I add the capacitor, it seems to only simulate once, and then not work correctly after that, or the simulation will just crash.

This is what I have in PSpice itself for this circuit with the above values: enter image description here

\$\endgroup\$
  • 2
    \$\begingroup\$ Why don't you have one of the nodes marked as ground? All spice programs I've used need exactly one of them. (A node called "0".) Otherwise the entire circuit is floating. \$\endgroup\$ – jonk Sep 14 '16 at 23:52
  • 1
    \$\begingroup\$ @jonk That diagram is actually just a diagram of what we're supposed to be making generally in PSpice, I've updated my post to reflect my actual circuit in PSpice that won't simulate correctly. \$\endgroup\$ – Yuerno Sep 15 '16 at 0:03
  • \$\begingroup\$ Ah. Okay. So.... that's weird then. Hmm. I've another thought. Will add it to my answer. \$\endgroup\$ – jonk Sep 15 '16 at 0:04
  • 1
    \$\begingroup\$ Try added a big valued resistor (100M or so) to your diode's anode to ground. \$\endgroup\$ – jonk Sep 15 '16 at 0:10
  • \$\begingroup\$ Not exactly an answer to your original question, but have you tried the same thing with LTspice? Same result? \$\endgroup\$ – winny Sep 15 '16 at 9:15
1
\$\begingroup\$

Try adding a ground node (see left side):

schematic

simulate this circuit – Schematic created using CircuitLab

The netlist would be something like:

R1 N2 0 5k

C1 N2 0 22µ

D1 N1 N2 1N914

V1 N1 0 SINE(0 3 1000)

Just note the use of 0 for ground.

EDIT: Okay. So you are using a ground. That's good. There is often a parameter to let you arbitrarily connect every node to ground via a high impedance value (GMIN.) But I don't know how you'd access it in your simulator. So lacking that, try the schematic on the right side, now, as shown above.

\$\endgroup\$
  • 1
    \$\begingroup\$ So after doing some fiddling around, it seems to be just a weird issue with PSpice. If I simulate the circuit, change my parameters, hit simulate immediately, it doesn't seem to work. If I give it a couple of minutes, then PSpice will do the simulation. Just to test if it was something wrong on the circuit's end, I tried simulating the same circuit using LTspice, where it worked immediately. \$\endgroup\$ – Yuerno Sep 15 '16 at 3:38
  • \$\begingroup\$ @Yuerno Okay. Looks like you have some problem with PSpice. You might look at the settings to see if you can find something. I'm glad you have LTspice as a backup plan. You may need it if you continue to have problems with your PSpice installation. Best wishes. \$\endgroup\$ – jonk Sep 15 '16 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.