3
\$\begingroup\$

I am an electronics hobbyist who has started dabbling in making circuit boards for my projects.

I have designed and fabricated a board for a solar powered sign I am making. The sign essentially consists of a Li-Po solar charging circuit (using a LT3652 chip), a boost converter (using a LTC3426 chip), and a Atmega328P-AU controlling some Neopixels.

I am a bit stumped at this point with my latest circuit board revision. The Atmega part of the board receives power from two sources:

  1. A 9-12VDC jack, which powers a 5V linear regulator.
  2. The solar/3.7V Li-Po setup.

When there is power present at the jack, it powers a linear regulator and at the same time activates a relay. The relay disconnects the batteries/solar/boost converter system from the Atmega side of the board, while connecting the output of the regulator. This part WORKS. When powered from the jack, everything operates normally.

Problem

However, I am having some issues when attempting to power the Atmega from the Li-Po batteries.

The sequence of operation for this circuit is:

  1. Power from the batteries is connected through the normally closed contacts of the above mentioned relay.
  2. That trace is connected to the source of a P-channel MOSFET. The MOSFET gate is pulled low by a push-button, which powers the 5V boost circuit from the drain of the MOSFET.
  3. The 5V boost circuit powers the Atmega328P, which then holds the MOSFET gate low, through an opto-isolator.

This set up worked on a previous revision of the board, however I did not have the opto-isolator. The resulted in voltage from the battery back feeding though the Atmega when the MOSFET was off (pulled high).

When the N.O. start switch is held closed, everything appears to operate normally. When the switch is released, the Atmega appears to be holding the MOSFET gate low, but the Atmega becomes unresponsive (stutters, restarts, hangs).

It seems to be a hardware problem, as it does this regardless of what sketch is loaded (or what is in the sketch).

Question:

What is wrong with my circuit design/implementation that could cause the issues described?

What I've tried

The Atmega runs fine and holds the MOSFET gate low if I remove the LTC3426 from the board (so that the 5V rail is being powered straight from the battery through the Schottky diode).

I tried replacing the LTC3426 chip with a second one that I had on had, with the same results.

If I remove the opto-isolator and 10k pull down, and jumper through the 1K load resistor and pads 1 and 4 of the opto (while changing the programming of the Atmega to reflect this), the everything also appears to operate normally (as it did in the previous revision).

Here are the schematics:

main schematic

enter image description here

from here

I also bought a scope, but I haven't developed the knowledge base yet to know much of what I'm looking at:

Battery voltage at rest (measurements taken at MOSFET):

Battery Button Pressed (everything working):

Battery Button Released (not working):

5V feeding the Atmega with button pressed

5V with button released

And this is the output of the inductor feeding pin 1 of the LTC3426:

Pressed:

Released:

\$\endgroup\$
  • \$\begingroup\$ FYI, even removing the deliberate space after "http" in each one, I can't get any of the links to other images to work. Can you please re-test them? Please include at least one of the working links in a comment (or edit it into the original question) so we can see what format the link should have. Then perhaps we can figure out the rest. Someone with enough "rep" can put the other images into the question, which you can't yet do as a new user. \$\endgroup\$ – SamGibson Sep 16 '16 at 23:01
  • \$\begingroup\$ You've defined your problem. Now ask some clear questions please. There is no question in your post. It helps readers to understand what your asking. electronics.stackexchange.com/help/how-to-ask \$\endgroup\$ – Voltage Spike Sep 16 '16 at 23:02
  • \$\begingroup\$ In the future please post your links with the link tool OR post actual images, links are discouraged. \$\endgroup\$ – Voltage Spike Sep 16 '16 at 23:03
  • \$\begingroup\$ @laptop2d - Hi - FYI as a new user, he can't post so many links or images (limit is 2 iirc). If he tried to post valid "http://..." links (or images - which are really links to that imgur site used by SE), the site complains about too many links being included and refuses to allow the question to be posted. \$\endgroup\$ – SamGibson Sep 16 '16 at 23:05
  • \$\begingroup\$ Right, edited post \$\endgroup\$ – Voltage Spike Sep 16 '16 at 23:15
1
\$\begingroup\$

The issue was not due to a component or schematic error, but rather due to poor component layout and lack of proper ground return path(s) on the circuit board. These issues were fixed on a further revision of the board and everything operates as intended.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.