2
\$\begingroup\$

i'm having a small problem when going to route my PCB in Altium version 9.4 - When I use the interactive routing tool and click it, it automatically completes the second part of the track, which i've found in tutorials and other documentation to only complete the initial perpendicular section and keep the second bit as a preview?

Any help would be greatly appreciated!

\$\endgroup\$
2
  • \$\begingroup\$ Your question is pretty unclear, some images and schematics would definitely help people answer your question. Remember we have no clue what the 'initial perpendicular section' we have no clue what your PCB looks like, so we cant answer a question about it. \$\endgroup\$ Oct 7, 2016 at 17:22
  • \$\begingroup\$ @ambitiose_sed_ineptum If you're familiar with Altium the question actually does make sense, but I agree, it would still be a good idea for the OP to post a couple of images \$\endgroup\$
    – DerStrom8
    Oct 7, 2016 at 17:52

1 Answer 1

2
\$\begingroup\$

What you're referring to is called "Look-Ahead" by Altium. It allows you to "preview" where the next trace will go without placing it immediately on mouse click. It sounds like you have it turned off. While routing, simply press the '1' key on your keyboard. The last segment of the track attached to your cursor should change from a hatched fill to no fill, which means the look-ahead feature is enabled. To disable look-ahead, simply press the '1' key again.

A couple images for reference:

Look-ahead enabled (places only horizontal hatched section on mouse click)- enter image description here

Look-ahead disabled (places both hatched sections on mouse click)- enter image description here

\$\endgroup\$
3
  • \$\begingroup\$ Hi DerStrom8 - thanks for taking the time to answer my question! This does appear to be the setting and when I do change this setting by pressing '1' it does change from hatched to non-hatched. However in either mode it still creates both parts of the track? \$\endgroup\$
    – Tricks
    Oct 11, 2016 at 17:44
  • \$\begingroup\$ Is there any other potential settings that may affect this? \$\endgroup\$
    – Tricks
    Oct 11, 2016 at 17:45
  • \$\begingroup\$ After changing it from hatched to non-hatched, if you don't want to complete the non-hatched section simply right-click to exit that track rather than left-clicking to place it. Without seeing exactly what you're doing it's a bit difficult to tell you what you might be doing wrong. \$\endgroup\$
    – DerStrom8
    Oct 12, 2016 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.