0
\$\begingroup\$

I am having a small but frustrating problem with Altium version 9.4. When I use the interactive routing tool on either the top or bottom layer the tool does not 'lock', indicated by the crosshair appearing, when hovered on the pin, but it instead automatically routes around the pin itself at all costs.

Is there any potential setting that I have changed that anyone knows of? I cannot find any help in their tutorials to change this. Below is a picture of the settings of my current interactive routing tool.

enter image description here

\$\endgroup\$
4
  • \$\begingroup\$ Are you on the same layer as the pins ? \$\endgroup\$
    – efox29
    Oct 11, 2016 at 17:52
  • 2
    \$\begingroup\$ The track will automatically go around something that it's not suppose to connect to or other obstacles. I believe that's what "Walkaround Obstacles" is doing. If you mean snapping to the electrical grid (e.g the center of a pad) when taking a track to the desired connection that is turned on/off using shift+e (I think). \$\endgroup\$ Oct 11, 2016 at 18:09
  • 1
    \$\begingroup\$ Does the schematic and netlist say that the track should connect to that pin? If you start a track other than on a pin or track already connected to a net, the new track won't have a net associated with it, so won't connect to anything. \$\endgroup\$ Oct 11, 2016 at 18:14
  • \$\begingroup\$ Hi - thanks everyone for taking the time to answer my question. The solution was DigitalNinja's - cheers! \$\endgroup\$
    – Tricks
    Oct 12, 2016 at 9:04

3 Answers 3

1
\$\begingroup\$

It sounds like the track and the pin are on different nets. Make sure the two are connected in the schematic and make sure both show the same net. You can check the nets by double-clicking the track or the pin and looking in the properties window at the "Net" setting. If they are different, Altium will not let you connect them. They MUST be connected in the schematic in order for the routing tool to let you connect them using a track.

\$\endgroup\$
2
  • \$\begingroup\$ Hi DerStrom8, thanks for answering my question however the solution to my problem was DigitalNinja's. \$\endgroup\$
    – Tricks
    Oct 12, 2016 at 9:04
  • 1
    \$\begingroup\$ DigitalNinja's comment was about walking around obstacles that the track shouldn't be connected to. Simply turning off the feature won't allow you to properly connect to the part if it doesn't have the same net. You may be able to place a track on top of a pad but if they don't have the same net they won't register to the software as being connected. Please make sure both objects have the same net before proceeding. \$\endgroup\$
    – DerStrom8
    Oct 12, 2016 at 11:58
1
\$\begingroup\$

It may be worth also looking at the nets of close-by copper: If there is something in the footprint which has no net or a different net your clearance rule applies and you can simply not reach the pad with active routing... I had this when designing a template for coplanar transmission lines. Took me a while to figure out that both, the surrounding ground planes generate a clearance boundary, and the inner conductor between the two pads (net tie) does not inherit the pads net as well, thus creating another clearance boundary. Increasing the pad size and clearance rule solved the problem, now I can reach the pad.

Coplanar transmission line template with indicated clearance boundaries

\$\endgroup\$
0
\$\begingroup\$

CTRL+E will fix this. If you inadvertantly type CTRL+E it will create this issue. Typing CTRL+E again will resolve this.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.