0
\$\begingroup\$

I have this board with LPC1768 and 32.768KHz crystal but the RTC does not work. By directing RTC clock to the CLKOUT pin I realized that there is no RTC clock so it makes sense that it's not working. But I have another prototype board (a small board) with LPC1768 and this one has no problem with the RTC. Now I changed crystal and two capacitors (RTC required components) of the prototype board with my board and the prototype board RTC kept working even with my boards components while RTC in my board still does not work with the prototype board components so I'm sure that it's not related to the components and their quality and things like that.
I must add up that besides RTC everything else works in my board without any sort of problems.
I suspect the MCU itself.
Now what do you make out of this ?

EDIT: 1- I almost forgot to mention that the crystal is located pretty much close to the MCU so I really do not suspect the layout.
2- Also the software is the same for this two boards so firmware problems is most unlikely.

\$\endgroup\$
  • 2
    \$\begingroup\$ Check the errata sheet: The RTC does not work for early LPC176x batches. This was fixed only in later revisions. \$\endgroup\$ – Turbo J Oct 12 '16 at 10:09
  • \$\begingroup\$ Are both MCUs programmed with the same firmware and all configuration options? \$\endgroup\$ – Brian Drummond Oct 12 '16 at 14:31
  • \$\begingroup\$ @brian Yeah ! You bet. I just soldered another mcu on an old board and seems like its working so I really suspect the mcu \$\endgroup\$ – mostafanfs Oct 12 '16 at 15:12
  • \$\begingroup\$ @turbo I have seen this but my mcu is from second revision and I've seen that this version has worked on other boards. But it could be that. You never know. I decided to let go of this cause its pointless and start building another board. \$\endgroup\$ – mostafanfs Oct 12 '16 at 15:17
0
\$\begingroup\$

If RTC does not work - and it seems to be as simple as two caps and one crystal as you said - there're following options:

  • there's some software setting in the microcontroller which explicitly tells circuit not to run RTC (in other words - disable it);
  • there's some conductor or via damaged in the caps/crystal circuit, or short circuit;
  • the microcontroller is having problems... this seems to be the worst case.
\$\endgroup\$
  • \$\begingroup\$ Software is the same for these two boards \$\endgroup\$ – mostafanfs Oct 12 '16 at 9:46
  • \$\begingroup\$ @mostafanfs where software is located for this chip? Can you tell in which locations you checked? And another question - did the board's RTC under question ever worked before? \$\endgroup\$ – Anonymous Oct 12 '16 at 9:49
  • \$\begingroup\$ I don't understand. Software located ? No it has never worked for this particular mcu and board. I just soldered another mcu and it worked ! \$\endgroup\$ – mostafanfs Oct 12 '16 at 15:14
0
\$\begingroup\$

Well I soldered another LPC1768 on this board and now RTC is working fine.
Apparently there is something wrong with some of LPC1768 chips. (But both chips have been marked as second revision!!)

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.