1
\$\begingroup\$

I'm simulating a virtual Arduino on Proteus. When I test my code, This error appear:

Simulation is not running in real time due to excessive CPU load

For me, It does not matter to watch the real time output wave form. Can I record it and see it later or something like that to solve this issue? I just need to see the first 5 seconds of the output wave form?

\$\endgroup\$
5
  • 2
    \$\begingroup\$ It looks like a warning, not error. \$\endgroup\$
    – Eugene Sh.
    Oct 14 '16 at 13:32
  • \$\begingroup\$ The output voltage should alternate between HIGH and LOW each second but it does not. It is always HIGH. Is that because of the warning or my codes are wrong? It worked before when the code was simpler and when there was no warning. \$\endgroup\$ Oct 15 '16 at 18:21
  • \$\begingroup\$ It is possible to run proteus at a slowed down speed?, not in real time?, i.e. to use x0.5 or x0.25? \$\endgroup\$
    – Brethlosze
    Feb 9 '18 at 15:59
  • \$\begingroup\$ I know it's old but ajithtomy's solution fixed this issue for me. Reduce the clockspeed in the settings/properties for the simulated Arduino. There might be some performance issues to work out but for simulation purposes, it does the trick for the most part. \$\endgroup\$ Apr 17 '20 at 20:37
2
\$\begingroup\$

That's due to 16mhz cpu speed Search for 1mhz 9600baud rate Arduino Uno board generate hex and load into proteous issue solved

\$\endgroup\$
1
  • \$\begingroup\$ Please use complete sentences with punctuation. \$\endgroup\$
    – Bort
    May 9 '17 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.