8
\$\begingroup\$

I am having trouble with a board I have had fabricated. The processor is an NXP LPC1788 Cortex-M3.

I am using a 12 MHz external crystal to clock the processor as recommended in the datasheet.

For some reason I cannot get the crystal to oscillate. I'm unsure if I am checking it correctly on my scope, but I cannot see any consistent oscillation.

Here is the datasheet for the crystal: http://www.txccrystal.com/images/pdf/8z.pdf.

It has a load capacitance of 18 pF, the LPC1788 datasheet recommends external load capacitors of 39 pF with a crystal of load capacitance of 20 pF, so I have tried 39 pF load capacitors with no joy. I have also tried 18 pF load capacitors as recommended by LPC1788 datasheet for crystals with approximately 10 pF load capacitance.

I would really like to at least understand why the crystal is failing to oscillate before I do another run of the board, as it is quite expensive (four-layer board).

Here is an image of the crystal routing.

Enter image description here

\$\endgroup\$
  • 2
    \$\begingroup\$ How do you that it's not oscillating? Can the processor not find a clock, or do you see nothing on the scope? A typical passive scope probe has 100 pF of capacitance and 1 MΩ of resistance, which could cause the crystal to stop oscillating. Switch to 10x mode (or 100x, if you've got it) or use another measurement method. \$\endgroup\$ – Kevin Vermeer Feb 9 '12 at 12:43
  • 1
    \$\begingroup\$ Have you checked the oscillator tracks for continuity? Does the chip work OK with the internal oscillator? \$\endgroup\$ – Leon Heller Feb 9 '12 at 13:07
  • \$\begingroup\$ Found that my crystal footprint was wrong, so I rotated the crystal and its working now. Thanks for your input. \$\endgroup\$ – James Feb 9 '12 at 13:08
8
\$\begingroup\$

I am looking pretty silly now... the footprint (I created, unfortunately) of the crystal was incorrectly pinned, and so I've rotated the crystal 90 degrees and put the 39pF caps back on and its now correctly oscillating. I should have checked this before bothering you guys!

Checked with 10X probe.

enter image description here

Sorry for wasting anyones time!

\$\endgroup\$
  • 2
    \$\begingroup\$ Happens to me all the time. \$\endgroup\$ – Rocketmagnet Feb 9 '12 at 13:13
  • 1
    \$\begingroup\$ Don't forget to accept this answer when you can (should be possible in two days). \$\endgroup\$ – AndrejaKo Feb 9 '12 at 15:13
  • \$\begingroup\$ This is going to be the solution for 80% of people whom are stuck. \$\endgroup\$ – Kortuk Feb 10 '12 at 5:16
  • \$\begingroup\$ Not a problem - this will be a good heads-up someday for someone in a similar situation. Or, maybe having read it, someone will avoid the mistake. \$\endgroup\$ – JRobert Feb 10 '12 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.