0
\$\begingroup\$

I wrote a simple assembly program and the uploaded it to the PIC16F1939 in the laboratory, and everything worked just as as expected (the LEDs blinked as they were supposed to). However, I tried uploading the same file to the proteus model of the same microcontroller, and nothing happened: enter image description here I adjusted the clock frequency. The only problematic part could be the program configuration words. How do I set those? In the pic above you can see the values 0x00 and 0x04 I typed in after the simulation failed with the ones that came as default in proteus.

\$\endgroup\$
2
  • \$\begingroup\$ Are you using an 'Animated LED'? Have you checked what is the forward current and forward voltage configured in the animated LED properties? Is the resistor consistent with those values? If current is too low, Proteus won't lit the animated LED. \$\endgroup\$
    – jmgonet
    Oct 26, 2016 at 8:02
  • \$\begingroup\$ Also, Proteus is not very friendly with not having *.dsn or *.pdsprj file in the root folder of your program folder. \$\endgroup\$
    – jmgonet
    Oct 26, 2016 at 8:07

1 Answer 1

3
\$\begingroup\$

If you are using Proteus Demonstration, they won´t run.

In Proteus Demonstration you only can run Samples and change the code, but the schemmatic.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ You have attempted to answer. You do not have enough score to comment. Hence here is the +1 :) the question is little old, by the way. \$\endgroup\$
    – User323693
    Feb 16, 2017 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.