0
\$\begingroup\$

I am new to the USBasp. I am trying to program a Mega1284.

I have a cheap Chinese one, it is recognized in XP as well as win7. I made a board with a ZIF socket, 10 MHz xtal, 22p cap, 10k pullup on the reset, external power and 2x5 pin header. The requisite connections to the header have been made (MOSI, MISO, SCK, /RESET).

No luck with Bascom AVR or extreme burner. Anything in XP tells me no USBasp device found, device manager sees it and it quite happy with it.

In win7, the same efforts just yield a failure to communicate with chip message.

All different drivers have been tried as mentioned over and over in various places. No luck whatsoever.

I have the power jumper on the USBasp open as I am supplying my own power to the mcu.

I am guessing I have a junk programmer. Anyone have any thoguhts to the contrary?

Thanks.

\$\endgroup\$
  • \$\begingroup\$ Is AVCC and all GND pins are connected as well? Also try with AVRpal.NET application, this was the only one that worked for me on windows 7. \$\endgroup\$ – Bence Kaulics Oct 29 '16 at 15:04
  • \$\begingroup\$ AVCC and GND are connected (GND on header pins 8 & 10 are, pins 3, 4, and 6 are open). Tried AVRpal, it too reported that the chip was not responding (win7), seemed to see the programmer, as did the others. In XP it didn't work at all. I am thinking this $5 programmer is bad. What is a good reliable one, from Fischl perhaps? \$\endgroup\$ – carpboy Oct 29 '16 at 22:26
  • \$\begingroup\$ In desperation, I started trying other USB ports on the two laptops. To my surprise, I found one that worked on both the XP and win7 box. Not all software does admit this, but several (extreme burner, avrpal, and avrdude) do in some form communicate. I can't get any of them to recognize the mcu (mega1284 and 1284p), but that is another matter. \$\endgroup\$ – carpboy Oct 30 '16 at 22:03
1
\$\begingroup\$

The problem with the cheap Chinese USBasp modules is that they come with a custom firmware, so they can be sold cheaper. I had the same problem, and after some research, asking some friends, they insisted me the following solution which worked for me. The prerequisite is to have another working programmer handy or make an Arduino as AVRisp and fix the USBasp (I used the arduino method).

If you have a working programmer, you can reprogram your USBasp with the latest official firmware found here. When reprogramming the "junk" USBasp, you have to put a jumper in "JP2" in the board to be programmed.

For a software to upload your hex file on the MCU i would suggest using the Khazama AVR, which is very easy and helpful. You can find it in this link.

When i reprogrammed my USBasp, i used Khazama and it perfectly worked, but any programmer will work. I just proposed Khazama because it has very few steps to do for downloading the hex file on the MCU, so you don't get confused with it.

Hope i helped!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.