4
\$\begingroup\$

Is there any way to route a track in KiCad 4.0 at a non-45° angle? I've searched for half an hour now and all I could find was this bug which mentions a "routing options" menu that I can't find, and a "Free angle mode" inside that which I can't find any mention of either.

All I want to do is draw a track between any two points on the grid without the 45° bend in the middle, but I just can't seem to figure it out.

\$\endgroup\$
4
\$\begingroup\$

"Free Angle Mode" only works together with "Highlight Collisions" mode.

The "Walk Around" and "Push/Shove" algorithms usually generate multiple new segments at a time, and the points in the middle are determined by the intersection points of two traces with a 45 degree angle between them. Using different angles here would give the router more degrees of freedom than it can use.

So, the only way currently is to allow arbitrary angles and use a routing mode where all control points are placed manually.

\$\endgroup\$
  • 1
    \$\begingroup\$ While I appreciate the detailed answer, I don't know how to make any of the changes you outlined, nor what those algorithms are you're talking about. I don't want to use the auto-router, if that's what you're talking about. \$\endgroup\$ – iFreilicht Oct 30 '16 at 16:57
  • \$\begingroup\$ @iFreilicht, these settings are in the Preferences -> Interactive Routing dialog. \$\endgroup\$ – Simon Richter Oct 30 '16 at 17:13
  • \$\begingroup\$ That entry is greyed out for me. \$\endgroup\$ – iFreilicht Oct 30 '16 at 17:23
  • 2
    \$\begingroup\$ @iFreilicht, then you are using the legacy canvas. Try switching to OpenGL mode (F11 or View -> Switch Canvas to OpenGL). The legacy canvas is going to be removed at some point. \$\endgroup\$ – Simon Richter Oct 30 '16 at 18:25
4
\$\begingroup\$

In the menu bar, open ´Preferences -> General´:

General Settings Window

The option "Limit tracks to 45 degrees" is normally on. Turning it off let's you draw tracks directly between two points at arbitrary angles. The bugreport in my question says it doesn't work, but apparently that has been fixed.

\$\endgroup\$
  • \$\begingroup\$ That setting only allows arbitrary angles (it should be synchronized with the same setting in the "Interactive Router" dialog) but you also need to use a routing mode that will actually use them. \$\endgroup\$ – Simon Richter Oct 30 '16 at 17:15
  • \$\begingroup\$ @SimonRichter It does exactly what I want, I can place every single trace arbitrarily. \$\endgroup\$ – iFreilicht Oct 30 '16 at 17:22
0
\$\begingroup\$

I have seen this one too; in the same link you showed the bug, it seems that one option its to rotate the board instead of the tracks or components, (well thats one way to do this!); other way is to check out this page and the comments, hope this is helpful!!

Good luck!

\$\endgroup\$
  • 1
    \$\begingroup\$ I found that as well, but it's not very helpful, it requires way too many steps and I don't want to set the angle fix, I just want to draw arbitrary angles. \$\endgroup\$ – iFreilicht Oct 30 '16 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.