0
\$\begingroup\$

I have designed a 5v and a 3.3v regulator getting same source of 12v battery. When I measure, the 5v regulator output shows -4.67v for + on black probe and - on red probe, and 5.12v when red is connected to + and black to -.

Similarly for 3.3v regulator...

Now I have an Arduino project and it includes a flow sensor. This project works fine if the serial port is connected to a laptop. But if I only connect an external power supply as described above, the sensor gives some output even if there is no flow.....

[The second problem involving a flow sensor has now been asked in a separate question here.]

\$\endgroup\$
  • \$\begingroup\$ Sounds like you need a new DMM. \$\endgroup\$ – Ignacio Vazquez-Abrams Nov 11 '16 at 9:01
  • 3
    \$\begingroup\$ Put a new battery in the DMM. If that doesn't fix it stop buying cheap test equipment and get yourself a decent DMM. \$\endgroup\$ – Andrew Nov 11 '16 at 9:11
  • \$\begingroup\$ Start to measure across your 12 V battery first. If not ok follow advise of Andrew. It could be that there is an AC component disturbing the results. But start with the above. \$\endgroup\$ – Decapod Nov 11 '16 at 9:14
  • \$\begingroup\$ I replaced a battery of multimeter,and it works fine \$\endgroup\$ – Arman T Dec 4 '16 at 5:23
  • \$\begingroup\$ But i thought other issue is because of this....what about other problem of arduino sensor \$\endgroup\$ – Arman T Dec 4 '16 at 5:24
3
\$\begingroup\$

Different positive and negative readings on a dual-slope ADC can be caused by the maker using a crummy integrating capacitor with a large amount of dielectric absorption. It's also possible the battery is dying and the integrator is saturating on one side but not the other.


Your other issue sounds like a grounding problem.

\$\endgroup\$
  • \$\begingroup\$ thanx, but how to solve grounding problem \$\endgroup\$ – Arman T Dec 4 '16 at 16:04
  • \$\begingroup\$ The laptop may be supplying a ground and you may be missing that ground in your circuit. \$\endgroup\$ – Spehro Pefhany Dec 4 '16 at 16:25
  • 1
    \$\begingroup\$ @ArmanT - Since you have now asked your second problem in this new question please stop asking about it here as well. Otherwise you are wasting people's time duplicating effort in both questions. I will edit your question here, so that the second problem points to your new question. \$\endgroup\$ – SamGibson Dec 4 '16 at 19:00
4
\$\begingroup\$

It would be reasonable to expect a DMM to read the same to within one count, maybe two, when reversing the leads. There are factors like linearity, and contact potentials with the leads, that could give rise to not exactly the same reading without cause for concern.

The difference you report is too big to be ignored. It's possible your meter is faulty. Measure a battery both ways round to check. Use another meter (borrow one, but at £3, always keep a second meter around as a spare) to check. Is the battery in the meter OK? It may say it's OK, measure it to check (with your 2nd meter!)

It's also possible that your power supply is oscillating, and the different connection of your meter is, through placement of the leads affecting the loading capacitance, affecting how or whether it oscillates. Try changing the length/placement of the leads to investigate this possibility. Any unexpected results are worth investigating.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.