3
\$\begingroup\$

I tried to run LCD software in Keil for STM32, but I got

*** error 65: access violation at 0x60000000 : no 'write' permission

Do you know how to solve that error ? I saw that I can create a MAP, but it didn't work

MAP  0x00000000, 0x70000000  READ WRITE  // allow R/W access to IO space

Click for full resolution

(Click for full resolution image)

from this definition :

#define LCD_REG              (*((volatile unsigned short *) 0x60000000)) /* RS = 0 */
#define LCD_RAM              (*((volatile unsigned short *) 0x60020000)) /* RS = 1 */

Thanks for reading

I'm using simulator enter image description here

\$\endgroup\$
  • \$\begingroup\$ i followed this video to resolve the same issue related to access violation when i try to use keil in simulator mode youtu.be/gEedJNB2WfM \$\endgroup\$ – user102299 Mar 3 '16 at 5:29
1
\$\begingroup\$

Try going to:

Project -> Options for Target '<your target>' -> Debug tab

and select the debugger option. enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ then what should I do ? I don't have ULINK, can't I use simulator ? \$\endgroup\$ – Rick Ant Feb 25 '12 at 9:48
  • \$\begingroup\$ I was under impression that you wanted to run the code on a microcontroller, in which case you would choose an appropriate debugger from the list (not necessarily a ulink). I have not tried using a simulator yet, so won't be able to help with that, sorry. \$\endgroup\$ – Armandas Feb 25 '12 at 14:45
  • 1
    \$\begingroup\$ I'm not using ULink as my debugger, I'm using simulator \$\endgroup\$ – Rick Ant Feb 27 '12 at 1:32
  • \$\begingroup\$ So I need to have ULink or Jlink and the board..? \$\endgroup\$ – Rick Ant Mar 12 '12 at 12:30
  • \$\begingroup\$ @RickAnt - you should not accept an answer that does not solve your problem. \$\endgroup\$ – Chris Stratton Nov 10 '15 at 16:05
3
\$\begingroup\$

If you want to use the simulator:

  • select the simulator in project properties on the debug page
  • start a debugging session. Don't run the code yet
  • go to Debug -> Memory Map... and manually map the ranges the simulator cannot find.

For example:

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Welcome to EE.SE, this is not a forum. Your answer is better suited as a comment as it doesn't aim to solve the given question. \$\endgroup\$ – Funkyguy Aug 20 '15 at 19:29
  • \$\begingroup\$ This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. \$\endgroup\$ – Daniel Grillo Aug 20 '15 at 20:39
  • \$\begingroup\$ @DanielGrillo - actually, this is an attempted answer to the specific part of the poster's question which concerned their inability to enact a map. Doing so may or may not solve the problem, but this is an entirely appropriate response to the question. \$\endgroup\$ – Chris Stratton Nov 10 '15 at 16:03
  • \$\begingroup\$ @ChrisStratton Have you seen it before Dmitry's edition? Now is much better to understand but at that time I couldn't. \$\endgroup\$ – Daniel Grillo Nov 10 '15 at 17:01
  • \$\begingroup\$ The information content was the same. Both before and after the edit, the answer is targeted at someone knee-deep in the problem, not an uninvolved reader. \$\endgroup\$ – Chris Stratton Nov 10 '15 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.