0
\$\begingroup\$

i have a problem trying to work with a signal whose amplitude is in nanovolts and has an offset of 1V. LTSpice doesn't plot the amplitude because is too small in comparation to the offset (the amplitude limit for plotting with the offset is 1 micro volt). Is there a way to make LTSpice more sensitive to these little amplitudes or force it to work with the signal? I need to amplify the signal but my amplifier needs the offset to work, and LTSpice does not amplify anything because it does not recognize the waveform because of the little amplitude it has.

Thank you

\$\endgroup\$
  • 2
    \$\begingroup\$ There are tolerance settings (eg. abstol = 1e-10), however tighter tolerance can lead to convergence problems. Have you tried adding a bogus voltage source just to null out the offset? \$\endgroup\$ – Spehro Pefhany Nov 21 '16 at 1:24
1
\$\begingroup\$

If you are in Windows, go to the plot display pane of your signal in LTspice. At the top center, there is a nice "net" name there (could be more than one.) Right click on that and a dialog box will pop up. In the bottom half of that dialog box, is an area with a heading that says "Enter an algebraic expression to plot:". Underneath, you will see the equation used, currently. This is probably just a node name, for now. Move your cursor into the box, left click once to get your text cursor, and move around until you are at the end of the node name. Append "-1" to it. (Or some other value.) This will subtract "1" from the signal. (You said the offset is one, so this subtracts that from the signal." Now just click on the "OKAY" button in the upper right. The display will change. Or, if it doesn't seem to, just right click on the data curve itself and click on "Zoom to Fit." That should get it, if it didn't do so otherwise.

\$\endgroup\$
0
\$\begingroup\$

LTspice, by default, uses waveform compression, which is set to 300 points (IIRC). This means that any waveforms will be compressed to such a nature that displaying great differences in the dynamic range can be impossible. In this case, you have 1V (1e0) with a 1nV (1e-9), which can be problematic. You could try to solve this is by adding .opt plotwinsize=0 to your schematic, which will disable the waveform compression. Another is adding an imposing a timestep, but that's mostly for displaying high frequency content. You could also fiddle with abstol, reltol, trtol, volttol, etc.

But, in your case, I'm afraid the demand is just too great. I'm not sure even jonk's suggestion works. You can see that with all the tweaks, even a 1mVDC+1nVAC will be poorly rendered. In case your signal is "hand-made", you could try using two separate sources, one for the 1VDC and one for the 1nVAC, see if you can make it, or use a behavioural source (with no external signal) that directly uses the input signal in its calculations, but, unless I am terribly mistaken, no SPICE would differentiate between a nine orders of magnitude difference.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.