I created a PCB in EAGLE Cadsoft but Net names are invisible in PCB layer though all layers are selected to be visible. Any suggestion? (I need names to be shown like the "jp1" on top left corner of PCB layer as in below image)

enter image description here


Net names on tracks is available on Eagle 7.6.2 forward.

If you have an appropriate version of Eagle, you can:

Enable signal names on nets under the Misc button, found under Options > Set from the EAGLE menu.

enter image description here

  • \$\begingroup\$ Thanks but I'm using EAGLE 7.7 windows 32bit version which doesn't have this option. \$\endgroup\$ – Mehran Nov 21 '16 at 10:20
  • \$\begingroup\$ @Mehran -- Ok, so I just downloaded and installed Eagle 7.7 on Windows and it has this option and its enabled by default. It shows the track name if I zoom in past a threshold. \$\endgroup\$ – Wesley Lee Nov 21 '16 at 10:40
  • \$\begingroup\$ Actually I want names to be shown like the "jp1" on top left corner of PCB layer. Is it possible or I should add labels manually? \$\endgroup\$ – Mehran Nov 21 '16 at 10:52
  • \$\begingroup\$ AFAIK the names appear on the tracks only as a pointer/help when routing, if you want them to appear on the PCB I'm afraid you'll have to add them manually. \$\endgroup\$ – Wesley Lee Nov 21 '16 at 10:53
  • \$\begingroup\$ You could write a script to do that, either a ulp or just processing the XML files in something else (while Eagle does not have them open of course). Beware though that the results are likely to make a visual mess! \$\endgroup\$ – Chris Stratton Jul 30 '17 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.