1
\$\begingroup\$

EDIT: Solved. I misinterpreted Linear's use of the period character prior to the measurements and LTspice was reading these values on the hundred's of nm scale, which is too small for this transistor technology.

I am currently attempting to simulate an NMOS enhancement load inverter to retrieve it's Voltage Transfer Curve for various gains by sweeping the parameter W of the switching transistor (M1 in my circuit below). From Linear's website, I found an explanation of the .step Spice directive where it matches the following formula:

.step param [variable] list [val1] [val2] ... [valn]

Their example (Parameter Sweep Solution - Linear) involves sweeping the capacitance of a capacitor.

I am running into errors while trying to sweep regarding the width being less than or equal to 0. Is there a different format for the directive when sweeping a device's parameters?

My circuit is below:

NMOS Enhancement Mode Inverter Circuit

\$\endgroup\$
3
  • \$\begingroup\$ Does it work when you manually set M1 w=.20u? \$\endgroup\$
    – W5VO
    Commented Nov 22, 2016 at 16:00
  • \$\begingroup\$ No, and I've realized the issue. I had interpreted the period in Linear's example as simply part of the format prior to each value, not as part of the number. The issue is that it was treating the number as 200n which is too small of a width for the transistor technology the model implements. \$\endgroup\$ Commented Nov 22, 2016 at 16:08
  • 2
    \$\begingroup\$ If you solved it, please post an answer. This will let you mark it as solved and then the robot overlords will quit pushing your question to the front page looking for answers. \$\endgroup\$
    – The Photon
    Commented Nov 22, 2016 at 16:51

1 Answer 1

3
\$\begingroup\$

The syntax of the step Spice directive is correct, however I misinterpreted the use of the period character.

I have changed the directive to read ".step param w list 20u 80u 320u" and got the intended results.

The problem was that with the period the values were being read as 200n, 800n, and 320n respectively. This is smaller than the model I was using allowed for which resulted in the error.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.