2
\$\begingroup\$

I bought an XBee-PRO S1 .. I built its serial explorer to be able to configure it through the PC, I’m using X-CTU to configure and test it at first it worked well,I made test/query successfully many times I tried to write a modem configuration to it .. but each time ended with a failed message, through this the chip was still responding to the test/query, and the terminal command "+++", but trying to configure it 3 or 4 more times it stopped responding, well, I figured I was wrongly configuring it, as I didn't use the reset to reset the chip before writing the new configuration to it .. then i fixed my explorer circuit, and tried using a reset button, it worked one or two times, and a progress bar appeared, but the process failed too .. now the XBee isn't responding any more for any of what I did before .. I searched, and found many people facing the same problem ..

This problem happened with two modules in row .....

In short “I write +++ it responds OK , If started to configure say AT..anything , It stops & no respond , if I tried “+++” again .. no respond , it’s even not recognized by the X-CTU” ...

I hope I can find help about what should I do to recover this XBee, and what mistakes did I do so I can avoid them in future .........

Update #1:-

I contacted the manufacture digi(dot).com

Support: In order to change the firmware on the radio, the DTR and RTS lines are required. To resolve your issue, I would recommend either acquire one of our XBIB interface boars or you follow the steps outlined at http://www.youtube.com/watch?v=fxOqQZD-oaM once the DTR and RTS lines are connected using the proper level shifting.

As described in the product manual, the radio is a 3V device and is NOT 5V or RS232 level tolerant. You need to use a level shifter between the radio and the PC or some other Non 3V CMOS level device. Otherwise you will damage the module.

You can see a sample schematic of our XBIB interface boards buy going to http://www.digi.com/support/kbase/kbaseresultdetl?id=2118. However if you are not familiar with level shifting, I would strongly recommend acquiring one of our XBIB development boards as it will give you a known starting point to work from.

Me after the update :

Of course nothing worked from the support !

The behavior I noticed that :-

When I press the reset for a while (4 ~5 ) seconds , the CTS line in XCTU is lighted up(Green) ..... So ?

\$\endgroup\$
  • \$\begingroup\$ What kind of ranges are you wanting to transmit data over? \$\endgroup\$ – sptrks Feb 25 '12 at 22:25
  • 1
    \$\begingroup\$ @sptrks do you mean the frequency range ? .. 2.4 GHz .. as it is a free frequency for developing .. i also need it to transmit with a minimum radius 60 m \$\endgroup\$ – mina_g Feb 25 '12 at 22:46
  • 1
    \$\begingroup\$ @mina_g before your support ticket, were applying 5V signaling directly to the module without level shifting it to 3V signaling? If so you may have done permanent damage. \$\endgroup\$ – vicatcu Feb 28 '12 at 16:41
  • \$\begingroup\$ @vicatcu No, the VCC of the max232 is on 3.3 V (accurately 3.16 v), i measured its outputs going to the XBee, they are from 0 to 3.16 V \$\endgroup\$ – mina_g Feb 28 '12 at 17:38
  • 1
    \$\begingroup\$ after searching more, i think that my XBee bootloader is broken .. anyone has a solution or confirmation for this ?! \$\endgroup\$ – mina_g Feb 29 '12 at 21:51
2
\$\begingroup\$

I've just made an instructable for this problem. I have not proven them to work with Series 1 XBees yet, but this should be the same solution for each Series one and two. Try it and let me know the results! http://www.instructables.com/id/Restoring-your-broken-XBee/

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.