3
\$\begingroup\$

Does anybody know how to change the line spacing between the parameters in the schematic symbol without disabling the autoposition feature in Altium Designer? If I change the font (smaller) of the parameters, the line spacing is getting too big (see “Default”).

I want it to be like “Wanted” without moving every parameter on every component by hand.

Is this possible?

Another question is how to make sure that the parameters are shifted up if there are added more parameters to the schematic symbol. If I add two more parameters, it looks like in “More parameters”.

I want it to be like in “More parameters centered” as the first step and of course the answer to my first question would lead to the final solution “More parameters centered wanted”

The first question is my biggest problem and much more important than the second, because the schematic is getting too big because of those big line spacings.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ If the spacing is causing that much of a problem, why don't you move the parameters manually? You can click and drag each one to where you want it. \$\endgroup\$ – DerStrom8 Dec 7 '16 at 12:51
1
\$\begingroup\$

To fix this and have the change propagate to all instances of that part, you'll have to fix it at the schematic symbol level.

Go to the schematic library that contains the symbol (here, for your resistor). Tools -> Component Properties. Here is where you can add the parameters and which are visible.

Then on the symbol in the Schematic Library Editor, you can drag them around and position them how you like, centered or whatnot. You can have a different footprint that you use that adds the additional parameters.

Then save. This will now fix it for all future parts that you instantiate. To backfix all the parts already in your schematic, go to your schematic and click Tools -> Update from Libraries. You can fix all hierarchies at once, just one hierarchy, all parts, just a few, etc. You can control all those settings from that dialogue.

\$\endgroup\$
  • 1
    \$\begingroup\$ Thank you for your answer Joel, but this only works when the "autoposition" feature of Altium is disabled in the parameter properties of the schematic symbol in the schematic library editor. This leads to the other problem that if you rotate the part with the space bar in the schematic, the designator and the parameters stay in the wrong orientation. I'm looking for a solution to fix the spacing issue and to keep the autoposition feature when rotating the part. \$\endgroup\$ – electricar Dec 7 '16 at 20:13
  • \$\begingroup\$ OK, so I misunderstood the question, and yet two people have downvoted my answer on this. I'm the only one who even took the time to answer this as best I understood the question. Lame. \$\endgroup\$ – Joel Wigton Jan 25 '17 at 20:01
  • \$\begingroup\$ I'm sorry for that, I didn't downvote your answer. Today I had a conversation with an employee of Altium and he told me that there is no solution for changing the spacing but keeping the autoposition feature. \$\endgroup\$ – electricar Jan 25 '17 at 20:09
  • \$\begingroup\$ Wasn't implying you did but that others down voted. Since SE is a volunteer thing it's just lame since I put out a sincere attempt to answer. Anyway, w/e. Bummer you can't do what you want in Altium though! \$\endgroup\$ – Joel Wigton Jan 25 '17 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.