I have shared my circuit diagram in the image i have attached in this post. The problem i am facing here is , the esp8266-12e does not start in first attempt, I have to reset the module (or power on/off) multiple times and then it starts after number of attempts. The voltage reading in multi-meter shows appropriate all the times, even the voltage in ESP8266-12e module shows perfect. but the module does not start.

NOTE - Here module starting means, starting it in Access Point Mode. Image Diagram


  • \$\begingroup\$ Sounds like a lack of capacitance on the 3V3 rail since the ESP8266 draws a lot of current (albeit intermittently). The reference designs show either a 10µF or a 10µF and a 100nF capacitor; your schematic only shows a 100nF cap. One other minor thing is that you might want to put a 10kΩ resistor on the GPIO2 pull-up. \$\endgroup\$ Nov 27, 2021 at 6:04

3 Answers 3


The almost complete lack of decoupling in your schematic could be a factor. 100nF on the ESP supply rail is insufficient, during startup and transmission, the ESP can draw large current transients. I would start with 47uF and possibly more (and keep the 100nF). Additionally, you need decoupling on the PCF, at least 100n but 10u + 100n would be better, perhaps more depending on the size of LEDs you are driving.

Also, you haven't provided a picture of your circuit; that may give us insight into potential problems as well.

It is possible that some pins which the ESP checks for startup configuration are floating. I notice that you have GPIO2 tied to VCC; IIRC it is typically pulled up, shouldn't matter but may make a difference. Also, you have omitted the typical 100nF RST capacitor, that is also something you should add.

Finally, you don't provide details on your 3.3V supply. Is it possible that it is current-limiting during startup? If you have access to a scope, you should watch the 3V3 rail during startup to make sure it's not dropping out.

  • \$\begingroup\$ hi.very thanks for the guidance.i forgot to mention that i am new in electronics, still after reading this, few points i didn't understand they are : 1.you have omitted the typical 100nF RST capacitor, is my connection with capacitor wrong.?? 2. How shall i add 47uF in circuit, parallel or in series. (lack of Gk in me) 3. also when the esp starts; but doesn't work then in volt readings across Vcc and Gnd are 2.68V, when it works the readings are 2.93V. 4. I am not using LEDs , I am using 4 X 5v 4 Channel Relays . 5. There is separate power supply of 3.3v to esp8266 and 5v to relays. \$\endgroup\$ Dec 9, 2016 at 16:34
  • \$\begingroup\$ Hi , i tried following things here. 1. tried to replace C1 as 10uF. 2. tried to replace C1 as 47uF. the voltage goes to 2.8 , but doesn't cross 3v. Atleast 2.93v it should cross to make the esp work. any more solutions. \$\endgroup\$ Dec 10, 2016 at 9:28
  • \$\begingroup\$ i have updated the diagram image. \$\endgroup\$ Dec 10, 2016 at 19:12
  • \$\begingroup\$ @KarmaCoding - 2.93V is not enough for any stable operation IIRC, 2.8V certainly isn't. Check your PSU. uint128_t - all of my boards work without a RST cap and do so quite well. Must be something else, really. \$\endgroup\$ Dec 10, 2016 at 19:50
  • \$\begingroup\$ @KarmaCoding It sounds like your regulator is not capable of supplying a stable 3.3V as Арсений Пичугин has mentioned. Give us a better idea of your 3.3V supply. \$\endgroup\$
    – uint128_t
    Dec 10, 2016 at 23:58

What are you powering the ESP8266 from? This is an important question since I had same problems when I had a very bad 3.3V supply. Use a 1117 fixed on 3.3V or a similar regulator powered from 5V to make sure lack of power is not the problem you'll encounter. Oh, and caps on the power line! (though ESP8266-12 has some integrated IIRC)

  • \$\begingroup\$ i have been using step down transformer 6-0-6 V, 1A. and then the 7805 and Ams1117 for two windings. \$\endgroup\$ Dec 15, 2016 at 8:01
  • \$\begingroup\$ Nice! The grounds are connected, right? \$\endgroup\$ Dec 16, 2016 at 7:55
  • \$\begingroup\$ yes ,, they are connected. \$\endgroup\$ Dec 16, 2016 at 11:31

You have not mentioned which regulator you are using to provide the 3.3v. That may be useful to know.

In addition to the decoupling caps as others have mentioned, if you are prototyping this circuit on a breadboard you may check that the breadboard is not the source of your problems. On the ESP8266 forums many people have had a hard time delivering a stable enough power supply through low quality breadboards.

  • \$\begingroup\$ i have been using step down transformer 6-0-6 V, 1A. and then the 7805 and Ams1117 for two windings. \$\endgroup\$ Dec 15, 2016 at 8:01
  • \$\begingroup\$ Is the 1117 input coming from 6v or from the 7805? Is the input to 7805 6v? It has a 2v dropout IIRC (can you link the datasheets of your parte and post a schematic of your circuit). \$\endgroup\$
    – billbo
    Dec 15, 2016 at 11:54
  • \$\begingroup\$ Also, what is the current limit of your step down transformer? \$\endgroup\$
    – billbo
    Dec 15, 2016 at 11:56
  • \$\begingroup\$ the current limit for transformer is 1A. \$\endgroup\$ Dec 15, 2016 at 11:59
  • 1
    \$\begingroup\$ Let us continue this discussion in chat. \$\endgroup\$ Dec 15, 2016 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.