4
\$\begingroup\$

I have been trying to use a zener diode and cannot get it to work as expected. I have been searching forums and watching youtube videos without any luck, so hoping someone can explain it to me

I want to use a Particle Electron to measure a 12v supply, the Electron accepts 0-3.3v so I am using a voltage decider which is working fine, I want to use a zener diode as over voltage protection to clamp it at 3.3v

I have purchased multiple packs of zener diodes (thought the first might be faulty/incorrect) but am currently using:

https://www.jaycar.com.au/3-3v-1n4728-1-watt-zener-diode/p/ZR1398

I am attempting to test the diode using the following tutorial on youtube: https://www.youtube.com/watch?v=WdDFI1IRQds

I have a 5.1v supply (measured at 4.98v using multimeter), a 1K ohm resister and the diode, when I measure the voltage I get 2.15v. I expected this to be 3.3v (as the zener voltage of the diode).

Can someone please explain why it is 2.15v? I have attached a photo of the circuit. Thanks for the help in understanding it.

Zener diode circuit

Updated Diagram after changing the resistor based on feedback.

Diagram

\$\endgroup\$
  • 3
    \$\begingroup\$ Draw a schematic! Also, measure your input voltage with that multimeter. I don't trust that seven segment module. \$\endgroup\$ – winny Dec 13 '16 at 10:01
  • 5
    \$\begingroup\$ Although you have a 3.3V zener, the 3.3V is given at what is called the "Zener Test Current" in the datasheet. For your part this is 76mA. Your circuit allows just 2.85mA to flow through the zener, so the voltage you measure is much less than 3.3V. You would perhaps be better to use a lower wattage zener that has a 5mA or 10mA test current. Try a BZX84C3V3 which gives 3.3V at 5mA. \$\endgroup\$ – Steve G Dec 13 '16 at 10:03
  • \$\begingroup\$ Alternatively, using the zener diode that you already have, use a 22 ohm resistor. That will allow about 80mA to flow through the zener, which should give 3.3V across it. Beware that the 22 Ohm resistor may get a little hot. \$\endgroup\$ – Steve G Dec 13 '16 at 10:09
  • 1
    \$\begingroup\$ For accuracy I wouldn't use a zener clamp but a diode to Vcc (or a diode to a biased zener). \$\endgroup\$ – Wouter van Ooijen Dec 13 '16 at 10:09
  • \$\begingroup\$ Your diode is drawn backwards. You're showing it forward biased. If that's how you actually hooked it up, it's why your circuit doesn't work how you expect. \$\endgroup\$ – Kyle Bleyle Feb 27 '18 at 17:19
7
\$\begingroup\$

Can someone please explain why it is 2.15v?

If you look at the data sheet for the 1N4728 you will see this: -

enter image description here

I've added the bits in red i.e. I've taken the external zener voltage of 3.3 volts and subtracted from it the internal volt drop due to the impedance at the test current specified. Immediately you can see that a more realistic figure for the zener voltage at low currents is more like 2.5 volts. Look at this curve to see how poor the 1N4728 is at low currents compared to versions at higher voltages: -

enter image description here

At 10 mA, the graph suggests that the zener terminal voltage might only be 2 volts rising to over 3 volts at a current of about 50 mA. Compare this with the 1N4744 (15 volt zener) and you can see that it remains at or about 15 volts from 10 mA up to nearly 60 mA.

If you want a better solution for non-high powers you could consider the TL431 precision programmable shunt voltage reference: -

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Thanks for your comprehensive answer, it is starting to make sense now. \$\endgroup\$ – Edward Jones Dec 14 '16 at 1:18
  • \$\begingroup\$ What I don't understand is why the zener diode is still having an effect at under 3.3v when I change the resistor to bring the current inline with the graph you supplied. Example. If I change the resistor to 47ohms and set the voltage to 3.0v (checked with multimeter), I measure the current as 60mA. According to the graph it should have a zener voltage of around 3v, but when I introduce the diode the voltage drops to 2.56v. Is this just because I have low quality diode or am I missing something? \$\endgroup\$ – Edward Jones Dec 14 '16 at 1:25
  • \$\begingroup\$ I have added a diagram to show how I am testing it \$\endgroup\$ – Edward Jones Dec 14 '16 at 1:37
  • \$\begingroup\$ You have the led wired back to front in your diagram. Assuming this is just a diagram error, I have my doubts about the supplier called Jaycar. They could be buying sub standard rejects from a good supplier and shipping them as proper units. \$\endgroup\$ – Andy aka Dec 14 '16 at 9:24
5
\$\begingroup\$

Low voltage zeners have terrible Knee characteristics. In your example you would get closer to 3.3V if your resistor was say 100 ohms. In the good old bad old days (1960s) the old techs would say that you need about 20% of its power rating to flow through the zener. This would mean that a 3.3V 1 watt zener would like about 66mA. Low voltage new zeners don't seem to be any better. You can try LEDs as zeners but they are not much better. These days band gap based devices are cheap and perform much better.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.