2
\$\begingroup\$

I made a board for a weather station that has an Arduino chip on it with an ESP8266 WiFi module mounted right next to it.
When I power the board, the ESP8266 seems to be unable to connect to my WiFi network.
It took me a while to figure out why as the module worked perfectly fine when connected directly to a USB-to-serial converter and writing AT commands directly to it.

So I tried to connect the ESP8266 module to my board using a ~15cm ribbon cable and suddenly it all works.
Seems like there is some electromagnetic interference when the Arduino (board) and ESP8266 are placed close to each other.

Has anyone encountered this before and is there another solution than placing the 2 parts away from each other?

EDIT: Added pictures to clarify

This doesn't work:
This doesn't work

This works:
This works

\$\endgroup\$
2
\$\begingroup\$

Put that radio module close to the MCU while still connected via the ribbon cable. If it stops working, it really was radio interference (but I doubt it). If it still works, then it's something else. Maybe you have transients which are reduced by the cable. Maybe you have connections which are unaccounted for when you plug the module directly (the cable has 6 poles, while the connector has 8). Hard to tell without a schematic, really.

\$\endgroup\$
  • \$\begingroup\$ It's getting stranger by the minute: when I hold the module close to the MCU, while connected via the ribbon cable, it still works fine. I tried 100 angles and it keeps working. But when connected directly, no luck. So I tried stacking multiple female headers on top of the PCB header and after stacking 3 headers and connecting the module to the top one, it works (1 or 2 headers didn't work). Makes no sense at all... I guess for now I will just connect the module by cable, but it grinds my gear that I can't figure out why it happens :) \$\endgroup\$ – Ruud van Falier Dec 14 '16 at 14:37
  • \$\begingroup\$ It bothers you for a good reason: relying on a ribbon cable to fix deficiencies you were not able to identify is not an acceptable solution: the issues can reappear even with the cable if you change something. I would start by soldering bypass caps on power lines near your PIC and on the RF module (unless there are some already). A second step would be adding small resistors in series on data lines. \$\endgroup\$ – Dmitry Grigoryev Dec 14 '16 at 15:31
  • 3
    \$\begingroup\$ I took a look at the power line with the scope and saw there was a ripple. This ripple was removed out once the current reached the module if the module was connected using the cable. There was already an electrolytic capacitor on the power line, but it wasn't sufficient. Replacing it with a larger capacitor has solved it and now it works when the module is connected directly to the board. Thanks!! \$\endgroup\$ – Ruud van Falier Dec 15 '16 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.