1
\$\begingroup\$

I've made a simple linear power supply for micro-controller with a transformer and LM7805CV as seen in the picture.

LM7805CV input voltage is 35V and output without load is 5V but after connecting a minimum load like an LED with 1K resistor output voltage drop to 2.5V.

I've checked regulator input voltage and it's steady without any change but regulator input-output voltage increase to 32V which I think is the main reason for dropping voltage.

Transformer = 2x24V Center Tapped

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Try half wave rectifier if you don't have non-center tapped transformer ! Just remove diode D2 \$\endgroup\$ – Photon001 Dec 19 '16 at 10:14
  • 2
    \$\begingroup\$ You're certainly pushing the limit on all your components needlessly as @oceanp mentions. A 24V RMS transformer has a 34V peak output (\$V_p = V_{rms} \times \sqrt{2}\$). Your input cap is rated for abs. max 35V, as is your regulator. Not good operating conditions, especially as the voltage may be higher if the transformer input is higher than rated. \$\endgroup\$ – Tom Carpenter Dec 19 '16 at 10:21
  • \$\begingroup\$ @sDev can you confirm that you are using the TO220 version of the regulator (plastic block with three inline leads at one end and a bit of heatsink poking out the other) \$\endgroup\$ – RoyC Dec 19 '16 at 10:32
  • \$\begingroup\$ @Raj I need 24VDC for ultrasonic sensor and fan that's why I used full wave rectifier. The 5v is using to feed ATmega 328 micro. \$\endgroup\$ – sDev Dec 19 '16 at 11:25
  • 1
    \$\begingroup\$ Your voltage is too high, but there almost surely is another problem with your circuit. Maybe if you supplied a photo, and PCB layout it might be clearer. \$\endgroup\$ – Spehro Pefhany Dec 19 '16 at 12:41
0
\$\begingroup\$

35V is the Absolute Maximum the device can cope with and should not be considered an operating voltage. The recommended max input for the 7805 is actually 25V (https://www.sparkfun.com/datasheets/Components/LM7805.pdf) and even that is going to generate a lot of heat compared to an input of say 8 to 10V.
At 35V in the 7805 will generate 4mA x 30V = 120 mW of heat which I would not expect to heat up enough to trigger the thermal shutdown even with no heat sink but maybe...
You can greatly reduce the heat generated in the regulator by reducing the input voltage (minimum input is about 2 or 3V above the output voltage). You should still use a good heat sink if you want to draw more than a few mA.
It's normally recommended that the caps are connected close to the regulator to ensure stability. Not usually a problem with +ve regulators but maybe it's oscillating.

\$\endgroup\$
  • \$\begingroup\$ Thank you for recommendation I'm going to increase C3 to 10/100 nf as @oceanp stated and bring it closer to regulator if possible then if problem persist using full wave bridge on half of transformer. I'll post updates here. \$\endgroup\$ – sDev Dec 19 '16 at 12:09
  • \$\begingroup\$ Datasheet you've refereed to is different from one I'm using: datasheet.octopart.com/… \$\endgroup\$ – sDev Dec 19 '16 at 12:19
  • \$\begingroup\$ Let us continue this discussion in chat. \$\endgroup\$ – Photon001 Dec 19 '16 at 13:49
  • \$\begingroup\$ Full wave bridge across half the transformer will give you the same output voltage. \$\endgroup\$ – RoyC Dec 19 '16 at 16:21
  • \$\begingroup\$ I'm confirming using full wave bridge on half of transformer doesn't change input voltage and problem persist also increasing C3 to 10 or 100nf doesn't change anything at all. \$\endgroup\$ – sDev Dec 19 '16 at 18:29
2
\$\begingroup\$

Your input voltage to the regulator is way too high. You are generating V*I Watts in the regulator which is 30*your load current. These parts have a thermal protection circuit which will shut them down to protect themselves. You will probably find the part is getting hot.

You should be aiming for a voltage input to the regulator in the 10V region. To limit the power dissipation in the regulator aim for the lower end of the input voltage range rather than the higher.

If your thermal management is good it could be a stability problem consider increasing C3 to 10n and make sure it is right across the regulator output also add another small capacitor (30n) straight across the regulator input. .

If you really need to create 5V from such a high input voltage consider using a Buck switching regulator.

\$\endgroup\$
  • 1
    \$\begingroup\$ While very true and worth considering, I'm not sure this is the entire the problem here - a 1k resistor on the output is at most a 5mA load, which equates to 150mW dissipation in the regulator and shouldn't cause an issue (datasheet shows 100mA for 32V input @ 150*C at the limit) . \$\endgroup\$ – Tom Carpenter Dec 19 '16 at 10:19
  • \$\begingroup\$ @oceanp Do you think taking around 50-100 mA current from 7805 can cause heat or problem for the regulator? Main part of system using 24v so I had to using 24v transformer 5v output only using to feed ATmega 328 \$\endgroup\$ – sDev Dec 19 '16 at 11:53
  • 1
    \$\begingroup\$ @sDev if you try to pull 100mA with a 35V input, that is \$(35V-5V)\times0.1A=3W\$. That sucker is going to get hot as hell. \$\endgroup\$ – Tom Carpenter Dec 19 '16 at 11:55
  • \$\begingroup\$ Hotter than hell is an understatement a TO220 without an extra heatsink is about 50C/Watt this is going to be 150C above ambient. \$\endgroup\$ – RoyC Dec 19 '16 at 12:06
  • \$\begingroup\$ @Tom Carpenter Good point but currently voltage drop appear after 5mA draw without any heat sign on regulator. \$\endgroup\$ – sDev Dec 19 '16 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.