1
\$\begingroup\$

One of the multimeters I have is a cheap Craftsman 82140 65EA. Today I was using it and it was giving wildly high readings for everything. A battery that measured around 9V on a working multimeter read over 13V on this one and fluctuated. I also tried measuring a few other things. A batter reading 1.2V on other multimeters read over 1.5V. A 82ohm carbon film resistor registered around 94ohm and measured 81.2ohm on another multimeter.

I was wondering what might be wrong. I changed the battery and that didn't fix it. I tried swapping out the leads with another brand multimeter that was working and then the Craftsman started giving the correct readings. This doesn't make any sense. I know wires break, but why would it read higher values for voltage ? I would only expect higher readings on Ohms.

\$\endgroup\$
  • 2
    \$\begingroup\$ Do the original leads work again if you put them back? Bad test leads or poor contact (perhaps oxidation) can easily cause resistance measurements to be too high, since additional resistance is being contributed by the leads. Haven't figured out an explanation for reading voltage too high though. \$\endgroup\$ – Ben Voigt Jan 22 '17 at 2:08
  • 3
    \$\begingroup\$ Are you sure the battery you tried was actually fresh? The symptoms you describe are common with a dying battery. \$\endgroup\$ – Spehro Pefhany Jan 22 '17 at 3:24
  • 2
    \$\begingroup\$ As you have several meters, it's worth characterising their 'low battery' warnings, I was astonished when I cross-checked mine. Some meters read wrong (always high as their internal reference collapses) before their 'low battery' indicator comes on, not clever! If you have a variable power supply, use one meter to measure another's battery voltage, as you sweep it down and watch what it does. If you don't have a variable power supply (get one, very useful), then most meters use so little current that a potentiometer will do for this test, or a discharging very large electrolytic. \$\endgroup\$ – Neil_UK Jan 22 '17 at 6:53
  • 1
    \$\begingroup\$ Turns out +Ben Voight was right. I plugged back in the original leads and it works fine now. Weird. Now I guess to watch out for oxidation on the leads. I still wonder why this would cause a higher reading instead of a lower one. You should all put your comments as answers, they are all worthy of checking. \$\endgroup\$ – deltaray Jan 22 '17 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.