-1
\$\begingroup\$

enter image description here[![enter image description here][2]][2]I'm using MSP430F5131 and trying to program it by IAR Embedded Workbench while using the MSP-FET debugger.

A short background of the PCB:

After i compiled the code in IAR with not errors found , i connected the MSP-FET to the MSP430 in a Spi-Bi-Wire connection according to the datasheet. The MSP430 is placed in a PCB which includes 12V input voltage and 2 regulators of 5V and 3.3V . The MSP430 I/O's are connected according to the datasheet (including external pullup resistors and capacitors) along with the Spi-Bi-Wire connections. I energized the PCB with a 12V supply voltage , connected the MSP-FET's connector to a Header connector on the PCB and the other side connected to the PC by USB.

My problem is :

In the IAR , once i try to download the code into the MSP430 (by clicking the 'Download and Debug' button) it says that it needs a firmware update , so i clicked ok and download the new update , but when it tries to initialize hardware i encounter the error :

"Fatal error: Could not find device (or device not supported)

Session aborted!"

I have tried multiple things in order to find the solution - with no success .

Does the AVcc and AVss needs to be connected even if i dont use any analog options? coz its not connected to anything.

I also tried to download the program to the MSP430 with code composer studio but encounter the same error.

The error pops up even if i dont connect the MSP-FET to the MCU (only to the PC by the USB cable).

I have connected the MSP-FET to the MCU like that :

  • RST/NMI/SBWTDIO of the MCU to TDO/TDI pin 1 of the MSP-FET.
  • TEST/SBWTCK of the MCU to TCK pin 7 of the MSP-FET.
  • a 3.3V that is supplied from a regulator in the PCB to VCC_TOOL pin 2 of the MSP-FET.
  • GND of the PCB to GND pin 9 of the MSP-FET.

Here's the error message i get:

[![The Error window][2]][2]

Here's the IAR settings for the FET Debugger:

[![FET Debugger settings][3]][3]

[![enter image description here][2]][2]

\$\endgroup\$
  • 1
    \$\begingroup\$ I would say your circuit is not wired properly. \$\endgroup\$ – Eugene Sh. Jan 23 '17 at 15:36
  • 1
    \$\begingroup\$ NB! I have read your post once again more careful, and noticed that you have a mistake in the wiring, if you use local power suppl, then you need to connect you local 3.3V line to the pin 4 VCC_TARGET of MSP-FET, and not to pin 2. \$\endgroup\$ – GAttuso Jan 24 '17 at 12:59
  • 1
    \$\begingroup\$ Well, then my suggestion list would be: 1) As already mentioned above, check all power lines; 2) Go through debugger troubleshooting list; 3) Make sure that the debugger MSP-FET is really working (test it with some other board/launchpad); 4) Post your problem on TI forum; \$\endgroup\$ – GAttuso Jan 24 '17 at 14:49
  • 1
    \$\begingroup\$ I measured the voltage between DVcc and DVss and the call is 0.7V , isnt it supposed to be 3.3V? maybe thats the problem? \$\endgroup\$ – עומר דגן Jan 24 '17 at 15:33
  • 1
    \$\begingroup\$ Well, that's definitely IS a problem. MCU can not even run when the DVCC < 1.8V. Check your regulator. \$\endgroup\$ – GAttuso Jan 24 '17 at 15:52
0
\$\begingroup\$

You have definitely made a critical mistake by not connecting the AVCC and AVSS pins to the proper supply voltages (VCC, GND). You mention this board has worked before? I don't see how that is possible given these pins were connected to their proper supply even if the FET was providing your board power.

Can you post a picture of your PCB layout? Are you getting exactly 3.3V outside your linear regulator? Measure the voltage across C5 or C7 to find out. The error you're getting is typically a power supply issue, but I see you have shorted AVSS and AVCC in your previous posts.

\$\endgroup\$
  • \$\begingroup\$ I still havn't shorted the AVcc and AVss to DVcc and DVss - working on it . The voltage i get when i measure across C5 or C7 is 0.7V - This seems like the voltage of the regulator output for some reason , maybe 3.3v rail is shorted somewhere.... \$\endgroup\$ – עומר דגן Jan 30 '17 at 13:24
  • \$\begingroup\$ I'm sorry but i dont have the PCB layout only the Electronic schematic \$\endgroup\$ – עומר דגן Jan 30 '17 at 13:28
  • \$\begingroup\$ Troubleshoot the 3.3V regulator first then, can you post the entire schematic of that 3.3V section? The picture that is posted cuts the input side circuitry. \$\endgroup\$ – Pablo Gonzalez Jan 30 '17 at 20:59
  • \$\begingroup\$ Alright i posted the entire schmatic of the PCB at my first post \$\endgroup\$ – עומר דגן Feb 1 '17 at 11:13
  • \$\begingroup\$ Are you at least getting 5V across C3 and C4? \$\endgroup\$ – Pablo Gonzalez Feb 3 '17 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.