I have an Arduino Mega ADK board. I am trying to make the sample project that is distributed with the ADK, but I can's seem to get any devices to detect my board.

I have installed the firmware on the ADK board with arduino, and it compiles and transfers with no errors.

I have the DemoKit application installed on device (tried both Xoom and Nexus S). I never get past the first screen that says please plug in the adk board.

I have tried powering the board via USB and with a 9v, didn't make a difference.

Beyond installing the android apk, and the arduino firmware on the board is there something else I need to do in order to get this sample program working?

  • \$\begingroup\$ did you ever get this sorted? \$\endgroup\$ – cbrulak Mar 20 '12 at 22:58
  • \$\begingroup\$ Nope, Not really sure what else to try =/ \$\endgroup\$ – FoamyGuy Mar 21 '12 at 13:12
  • \$\begingroup\$ if you plug in the board to your computer can you get one of the simple tutorial apps working, like the flashing led? \$\endgroup\$ – cbrulak Mar 21 '12 at 15:32
  • \$\begingroup\$ Yes, Blink runs fine. \$\endgroup\$ – FoamyGuy Mar 22 '12 at 1:52
  • \$\begingroup\$ so, your board is ok. then perhaps there is either (i haven't tried running adk yet so i'm just going to guess) a) your device is missing a setting/switch turned on b) the software on your board hasn't been compiled properly. double check the tutorials. Do you have any friends/contacts that have tried this and you could plug in your board to their phone and vice versa? \$\endgroup\$ – cbrulak Mar 22 '12 at 17:01

I went back and added some log outputs to the ADK code and figured out that the demokit software was not making it through the setup method. Turns out it was hanging on this line:

init_joystick( 5 );

I commented this line out and all works well. I don't know if it matters but while I was doing all of this I had no components plugged in to my ADK board.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.