1
\$\begingroup\$

I have a project that is basically replacing my car's instrument panel with an Android device (a tablet). I managed to make everything work except for one thing: the Li-Ion battery of the tablet was heating up in the hot days (I live in Brazil). The solution that I found was to remove the tablet's Li-Ion battery and try to use a voltage regulator to replace it.

My first try was to use a 2A buck converter to drop the 12V battery voltage to 3.8V and use this as a power supply for the tablet. I managed to remove the flat cable used in the battery and soldered 3 wires (the positive and negative leads plus another wire that is probably a thermitor). Carefully using a multimeter I measured the resistance between the thermistor wire and the negative lead of the battery, it showed up something like 80kOhm. Then I adjusted the voltage regulator for 3.8V, connected the tablet wires accordingly and put a 80kOhm resistor between the thermistor wire and the negative lead.

When I tried to power on the tablet, nothing happened. I then increased the voltage to 4.3V (I read in the battery that I removed that the charging voltage was max 4.35V, so I thought that it was not a problem to try to increase the voltage a little bit) and this time it showed the Samsung logo for 3~5 seconds and turned off.

I was able to boot up the device and keep it running for some seconds with the following: besides powering it using the voltage regulator, I also plugged a USB charger in it. The boot, then, succeeded, it stayed on for some seconds and then powered off again.

Talking to a friend of mine that is an electrical engineer, he explained to me that these kind of devices sometimes have current peaks and that this 2A voltage regulator may not be able to handle the current peaks on GSM bursts and so on.

What I did then was to buy a 12A buck converter with both voltage regulation and current regulation (through potentiometers). Today I tried to use it, expecting it would work, unsuccessfully. I adjusted the voltage to 3.8V (also tried 4.3V as before) and adjusted the current to max current. The same thing happened. This time I used the multimeter to measure the current passing through the tablet and what I got was that when I try to power up it draws something like 200~300mA from the voltage regulator for 3~5s and then it powers off.

If someone could help me figure out why the voltage regulator it not working as expected, I would be grateful.

The 2A buck converter: The 2A buck converter

The 12A buck converter: The 12A buck converter

\$\endgroup\$
  • \$\begingroup\$ How long are your wires? Maybe place a cap as close to the tablet as possible? Also, the output of your buck converter might be noisy, it could interfere with operation. \$\endgroup\$ – Wesley Lee Jan 25 '17 at 18:39
  • \$\begingroup\$ Isn't there a 5V input on this tablet somewhere? You can run the tablet off that as well as charge the battery ... that should still work even without the battery. \$\endgroup\$ – Brian Drummond Jan 25 '17 at 18:54
  • \$\begingroup\$ @WesleyLee, the wires are ~2m I think, they are going from the instrument panel location to the glove compartment. I'll try to put a cap, thanks \$\endgroup\$ – rafaame Jan 25 '17 at 18:55
  • \$\begingroup\$ 80k sounds waaay to high from expirience. Try a 10k resistor \$\endgroup\$ – Adil Malik Jan 25 '17 at 23:06
  • \$\begingroup\$ @AdilMalik, some devices use 100k thermistors. Since OP measured 80k, I would guess this battery uses a 100k NTC. Since it is hot, the resistance is less than 100k. \$\endgroup\$ – mkeith Jan 26 '17 at 7:05
3
\$\begingroup\$

Try to power your tablet through 5V USB port without the battery installed. The tablet has battery management, replacing battery with voltage from regulator may flag the error causing shutdown.

\$\endgroup\$
  • \$\begingroup\$ Unlikely to work if the Tablet has battery management. \$\endgroup\$ – Jack Creasey Jan 25 '17 at 22:38
  • \$\begingroup\$ I tested what you suggested and it didn't work. \$\endgroup\$ – rafaame Jan 27 '17 at 11:42
0
\$\begingroup\$

Depending on the age of your Android tablet the third wire you assumed to be a Thermistor is likely a 1-wire interface to a battery management chip. If this is the case then your Tablet assumes the battery is faulty since it cannot read state of charge or terminal voltage.

\$\endgroup\$
  • \$\begingroup\$ Indeed there was a small management circuit in the battery. I removed the circuit from the battery carefully and soldered the voltage regulator output in the input of this circuit. Tried to power up the tablet and it didn't work. I also tried to put the long wire (that goes from the instrument panel to the glove compartment) between the management circuit and the battery output to see if it has something to do with the wire resistance, and the tablet powered up correctly. It just doesn't power up with the voltage regulator. \$\endgroup\$ – rafaame Jan 27 '17 at 11:49
  • \$\begingroup\$ There will be a process (consumers are never exposed to this) that trains the management chip to the battery. It will be a challenge to derive this without knowing what the chip is. Normally if a device is repaired the battery and the management chip would be replaced at the same time. The new battery would have a new serial number and the BIOS would reinitialize the battery system. It may be that the management chip expects to see the terminal voltage drop under load. I suggest you hook it up so it works on the battery, then record the off, starting and on terminal voltages. \$\endgroup\$ – Jack Creasey Jan 27 '17 at 16:02
  • \$\begingroup\$ Then you can work out the battery voltage profile. You might be able to make it work then by increasing the output resistance of the voltage regulator (small series resistor) to 'look' like a battery. \$\endgroup\$ – Jack Creasey Jan 27 '17 at 16:03
0
\$\begingroup\$

Another option is to disassemble the original battery pack. There will be a battery management board inside. Connect your new power supply to the terminals on the battery management board where the original battery was connected. Then connect the management board to the tablet as original.

This should work.

\$\endgroup\$
  • \$\begingroup\$ I tried that yesterday, take a look in my comment in the answer above. \$\endgroup\$ – rafaame Jan 27 '17 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.