3
\$\begingroup\$

I recently bought a UART WiFi module (this one) and configured it (wireless configuration method) with right SSID but wrong password (and I don't know what it is).

The problem is that I can't reset this module to its manufacturer settings and I can't connect to this module via serial port to configure it with some wire or cable. But I'm sure that my module is trying to connect my access point but with wrong WPA2-PSK based network key (because in logs of my access point I can see my module's MAC address that trying to connect but it can't)

So my questions:

  1. Why I can't connect my module to my PC using a USB to Serial Converter ? (something like this one) I tested this module (I mean USB-SERIAL converter) and I'm sure that it works pretty well with my atmega8 microcontroller. And I checked baud rates, stop bits. When sending commands via some terminal debugging applications (like hyper terminal or code vision's terminal program) it responds nothing.

  2. How can I reset this module to its manufacturer settings without connecting it to any PC using serial port? There is nothing in datasheet but a command that needs a serial connection to some PCs.

  3. How can I see what password this module trying to connect to my access point (that cause "wrong password" failure)? Is there anyway to find out?

  4. Is there anyway to create or configure a WiFi network that accepts any WPA2 network key? I tried to create an open wireless network without any security but this module fails to connect to it either. It skips non-WPA2-PSK based networks.

First of all I should send 3 plus "+++" via serial port and after that it should respond with "+OK" but nothing happens when doing this. What's the problem ?

\$\endgroup\$
  • 1
    \$\begingroup\$ Are you sure you covered all the "dumb" things like connecting its RS-232 Rx pin to Tx on the cable and cable's Tx to module's Rx and so on? Are you sure that hardware flow control is connected correctly? Did you check that the pins are getting correct voltages with an oscilloscope (even a sound-card based one would be enough to show simple serial communication) or a multimeter? \$\endgroup\$ – AndrejaKo Mar 18 '12 at 21:44
  • \$\begingroup\$ I checked them out right now. They are ok dear @AndrejaKo \$\endgroup\$ – Michel Gokan Mar 19 '12 at 8:09
  • \$\begingroup\$ I think I really messed my TLG10UA03 UART-Wifi module... It worked at first but then I don't know what wrong config I did (using UART WIFI config) but now It can't find it anymore while I can still connect to the COM port through terminal. However I know nothing about the language I'm suppose to do... nor if there's a way to reset the adapter to default settings while I can't access it through UART WIFI config any longer... If someone knows what I'm supposed to do, please, help me... :) Thanks, Elfege \$\endgroup\$ – user21951 Apr 1 '13 at 6:36
  • \$\begingroup\$ Answers should be reserved for trying to answer the original question. It sounds like you have an unrelated problem so should consider asking a new question, although you may want to be a bit more specific about what you've tried so far. \$\endgroup\$ – PeterJ Apr 1 '13 at 6:47
2
\$\begingroup\$

The manual has the user using hyperterminal to send a text-file with the contents of + in it. I think the escape is just +, not +++. Also, you have to wait a few seconds (two is default) of no serial activity before the escape character will work.

I'm not sure if sending a text-file causes the terminal to behave differently then just typing +, or +++, but it might be worth trying. Maybe it needs basically no delay between the three +++, or it does something else (if the escape char is just +)


Also, have you checked that your signals are not inverted? Maybe the usb-serial is defaulting to normally high, and the module wants normally-low, or vice-versa.


Confirmed in comments below as three + characters, or +++. You have to send it as a text file. I suspect that feeding hyperterminal a text file causes the three bytes to be sent as close to each other as possible, while typing them manually causes a ~200ms+ inter-character delay (e.g. as fast as you can manually hit the + key).

Apparently the device has a much shorter "enter AT control mode" timeout them other similar devices, (like xBees, or such).

\$\endgroup\$
  • \$\begingroup\$ i tried that too ... ( i mean one + ) ... nothing happened again. what you mean by normally high/low ? I don't know that ? \$\endgroup\$ – Michel Gokan Mar 31 '12 at 19:35
  • \$\begingroup\$ 3 plus should send immediately (as text file). Not + then + then +. its "+++" ! ... Thank You. \$\endgroup\$ – Michel Gokan Apr 7 '12 at 9:53
  • 1
    \$\begingroup\$ @Michel Kogan - Glad you got it working. I added the information that you confirmed to my answer. Good luck! \$\endgroup\$ – Connor Wolf Apr 8 '12 at 5:27
  • \$\begingroup\$ @ConnotWolf: Can you please answer my another question relative to this question, I got stucked with this module again :( electronics.stackexchange.com/questions/64093/… \$\endgroup\$ – Michel Gokan Apr 2 '13 at 7:49
  • \$\begingroup\$ I had the same problem and got it working by first sending +++ to the serial port (= I copy&pasted the characters into a terminal), then I was able to connect with the software provided on docs.google.com/file/d/…. Before pasting the +++, I could not connect to my module. \$\endgroup\$ – opyh Apr 6 '14 at 18:36
1
\$\begingroup\$
  1. Did you ensure that your USB-Serial adaptor is indeed using TTL levels and NOT RS-232?
  2. Did you ensure that your USB-Serial adaptor's ground is connected to the ground of the WiFi device.
  3. Did you attempt to use the "UART WiFI Config" PC software provided for the Wifi defice? http://www.elechouse.com/elechouse/images/product/UART%20WiFi%20Transparent%20Module/UART-WiFi_English.rar
\$\endgroup\$
  • \$\begingroup\$ 1-Its in ttl level.(and it works directly with my micro). 2- they are connected using 3.3 volt regulator, because my usb-serial adapter's output voltage is 5V. 3- yes i tried it first but it didn't find anything.. \$\endgroup\$ – Michel Gokan Apr 4 '12 at 4:54
  • 1
    \$\begingroup\$ Wow, sounds like one STUBBORN module :/ \$\endgroup\$ – Konsalik Apr 4 '12 at 8:43
  • \$\begingroup\$ :( ... i'm going to buy another model of TTL-USB converter tomorrow ... thanks for your suggestions \$\endgroup\$ – Michel Gokan Apr 4 '12 at 19:13
  • \$\begingroup\$ I bought new USB-TTL converter with a jumper in it (which you can choose 3.3V output or 5V output). But when I connect my module's VCC and Ground to it, USB-TTL converter disconnected from computer. ( I think because it uses 0.3A and computer's usb cannot provide such amperage ). what can I do ? \$\endgroup\$ – Michel Gokan Apr 7 '12 at 7:14
  • 1
    \$\begingroup\$ @MichelKogan - I would guess that whatever USB-serial module you have is using a FT232R USB-serial IC. The FT232R IC has a built-in 3.3V regulator, but it's only capable of supplying 50 mA. Many of the really, really cheap FTDI boards just use this for their "3.3V" output, rather then a proper regualtor that is capable of providing the full USB 500 mA. As such, that's probably why your USB-serial module is resetting. \$\endgroup\$ – Connor Wolf Apr 2 '13 at 10:19

protected by Community Feb 21 '14 at 16:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.