5
\$\begingroup\$

I want to get rid of the measurement label in the PCB (the double arrow showing the dimension) but I am not able to delete it. It is showing overlap errors with the bottom traces. How do I delete this? I am using Eagle 7.7.

Things I have tried:

  1. Hit the Delete button and tried to delete the arrows as well as other parts.

  2. Hit the Ripup button and tried deleting at multiple points.

Screenshot of PCB layout

\$\endgroup\$
  • \$\begingroup\$ I just tried typing "delete" and clicking over the text/numbers, its finicky, but it does work. \$\endgroup\$ – Wesley Lee Jan 29 '17 at 20:21
  • \$\begingroup\$ When I deleted the text/numbers, they got deleted but now the arrows remain \$\endgroup\$ – user1155386 Jan 29 '17 at 20:50
  • \$\begingroup\$ Weird. Here everything was gone. I'm using 7.3 though. \$\endgroup\$ – Wesley Lee Jan 29 '17 at 21:01
  • 1
    \$\begingroup\$ Try grouping the whole mess at bottom, then doing a delete on the group. Also, enable all layers when doing this. Delete will only delete things in visible layers. \$\endgroup\$ – Olin Lathrop Jan 29 '17 at 21:08
  • \$\begingroup\$ You need to delete one end of the dimension (which will depend on which you end you drew from first) \$\endgroup\$ – Tom Carpenter Jan 29 '17 at 21:36
6
\$\begingroup\$

The OP surely has solved this problem by now, but I found this question when faced with the same problem, so the answer will probably be helpful to somebody.

At the time of this writing the current version of Eagle is v8.3.2; the procedure may be different in other versions.

To delete a dimension, just choose the trash icon and then click somewhere in the "hot zone" for the dimension marker. Where is the hot zone? Ah, there's the rub: it is unmarked and very tiny. Random clicking in likely locations will generally miss it. Fortunately, though small and invisible, its size and position are predictable.

The hot zone is 1 mm tall and 1 mm wide wide. In the versions of Eagle I have used it is found positioned at the exact midpoint of the dimension line. An additional hot zone is found at the spot where the user clicked to begin creating the dimension, but this hot spot is less easily located.

The OP has also encountered a second problem that is very common: if you naively add a measurement (dimension) line, it will by default likely be placed on either the top or bottom layer. This is a bad idea because the lines will be treated as traces that may trigger DRC rules. The OP encountered this when the DRC complained about trace overlap errors.

AutoDesk recommends placing measurements on layer 47 (Measures). If you do so, you will not trigger DRC rules.

There is another common source of confusion when measurements are placed on the Top or Bottom layer: the default settings violate common DRC rules for line width and for font, so the DRC creates a hatched design covering the lines, arrowheads, and the text of the measurement. Even if the actual dimension is then successfully deleted, the hatched coverage remains, making it appear as if the dimension line and arrows still remain. This is the problem that user1155386 has noted in the comments above.

It is not possible to delete this phantom dimension line, but it will go away if the DRC is run again or if the file is closed and reopened.

I hope this answer will help somebody, because personally I found these problems somewhat frustrating and did not find any answers in the documentation or in other questions on this site or other sites.

\$\endgroup\$
1
\$\begingroup\$

In Eagle, to apply a tool on an element, you have to

  • Select the tool from tool box.
  • Find the origin (the + mark) of the element.
  • Click on that origin.

but the problem is there is no visible origin of the dimensions. As explained in previous answer, there are multiple zones on a dimension which act as the origin (pointed in green arrows below)

enter image description here

If finding the origin is giving me a hard time, I just use the Group tool

  • Select the entire area of the element isolating it using Group (if you can't isolate it, try disabling some unwanted layers through Layer Settings)
  • Select the desired tool from tool box
  • Right click on the selection
  • Select tool-name: Group
  • Done!

I also found that a dimension cannot be Move, Rotate, or Mirror alone in Eagle, but can be done if the dimension is stuck in a Group.

I'm on Autodesk Eagle 8.5.1 Linux.

\$\endgroup\$
  • \$\begingroup\$ I am using EAGLE 6.6.0. The above procedure worked. I used the middle of the line between the arrows and put a small delete-group around this hot zone. In my case, the dimension appeared at the layer tNames. I surpressed all other layers. Thanks Yasindu, Luer \$\endgroup\$ – user203211 Nov 3 '18 at 1:32
0
\$\begingroup\$

A good idea is in the left panel, select group, then you can select the area that contains the dimension mark. Then, you can use the delete icon to delete the group you marked. It works to me.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.