0
\$\begingroup\$

There is a problem with this circuit. The original document specified 3V for power supply. However, the capacitor 13 is only charges to around 0.8v and then stops when I used 3V and it doesn't trigger SCR 7. I tried 9v and it works sometimes with this voltage. When I disconnect the gate of SCR 7, it seems to be charging fully. I am using TICP106D SCR. In the original document the SCR was BRY55. Both are sensitive gate SCR as far as know, so they should (?) be interchangeable. I don't understand why the current is leaking this much through the gate. Do you have any suggestion? enter image description here

\$\endgroup\$
  • \$\begingroup\$ get a sensitive gate SCR. The 5 to 200uA is too high. try 1uA \$\endgroup\$ – Sunnyskyguy EE75 Jan 31 '17 at 23:05
  • \$\begingroup\$ It might be interesting to know what the purpose of the circuit is - that would make understanding what might be wrong with it easier \$\endgroup\$ – Marcus Müller Jan 31 '17 at 23:08
  • \$\begingroup\$ Do sensitive SCR have lower leak through gate? \$\endgroup\$ – Baphomet Jan 31 '17 at 23:09
  • \$\begingroup\$ It's a break wire alarm.@ Marcus \$\endgroup\$ – Baphomet Jan 31 '17 at 23:10
  • \$\begingroup\$ P010xx has 1uA Igt max or P0130AA or make your own with two 2n5088 \$\endgroup\$ – Sunnyskyguy EE75 Jan 31 '17 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.