0
\$\begingroup\$

I try to load a program into STM32L011K4 using J-Link. The mistakes I get and the steps I follow are as follows:

PROBLEM-1. J-link could not find STM32L011K4

My Steps:

  • Click options for TargetUtilitiesDebug SettingsAdd Unspecified Device (Cortex M0+)

  • Click options for TargetUtilitiesDebug Settings → Port (SW) and click OK.

PROBLEM-2. When I click to load (F8) the program, I got an error as below:

"JLink-Cortex Error: Flash Timeout.Reset the Target and try it again"

and I clicked OK.

Then I get an error like this:

"uVision: Error:Flash Download failed - "Cortex-M0+"

My Steps:

I changed Options For TargetTarget IROM1 and IRAM1 values, but I kept getting the same error. Also I tried to change values of Options For TargetDebug SettingsMax Clock, but nothing has changed.

Problem 2

\$\endgroup\$
  • \$\begingroup\$ What kind of board is it? Is it a reference board, one you made? Are you sure the chip works? \$\endgroup\$ – pgvoorhees Feb 23 '17 at 13:54
  • \$\begingroup\$ J-Link board version=9.2 (13-44;YY-WW). And I am sure chip is working, because I can load program and debug with used ST-Link/V2. \$\endgroup\$ – Purgoufr Feb 24 '17 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.