1
\$\begingroup\$

I'm using an ACS712 based current sensor board

(Exact here: http://tinkersphere.com/sensors/1244-hall-effect-current-sensor-breakout-acs712.html)

For testing purposes I have connected Vcc and GND to a bench power supply, OUT and Gnd to a general purpose oscilloscope and connected the terminal current sensing inputs in series to a 12V(rms) AC transformer powering a 12 Ohm load providing 1amp of current through the board.

However after switching the 12V ac supply a few the board cuts out producing a flat 2.5V DC output.

Initially I thought this could be thermal shut down however the chip is barely over room temp

Behaviour seems to be like the board is cutting out as the noise normally present on the output pin with no input is supressed.

All images in single imgur post

Images:

Scope output images

\$\endgroup\$
  • \$\begingroup\$ I would suggest measuring the current with a multimeter or something comparable to proof that there is really current. Perhaps your light switch dies because of the inductive load and has contact problems. Or there is a connection problem. \$\endgroup\$ – auoa Mar 1 '17 at 14:01
  • 1
    \$\begingroup\$ There is absolutely no reason why that should be happening. The only thing I can think of is an intermittent short on the current sense path that bypasses the sensor. If the sensor is outputting 2.5V, then VCC is obviously present. All the IC really needs is VCC. There is no enable pin or anything, and it is very robust against over-current. If all else fails, get a new sensor and see if the problem persists. \$\endgroup\$ – mkeith Mar 1 '17 at 17:05
  • 1
    \$\begingroup\$ I have about 4 identical boards and I've tried each of them with the same issue persisting. It seems as if its some sort of protection circuitry in the chip and fast switching of the AC causes the output to clamp at that 2.5V. The application I'm using them for is to sense current on a 24V AC pump which involved the pump switching, hence why this is an issue. Perhaps its a Chinese clone of the chip. I will take closer photos of the chip tomorrow and see if I can find the exact variant or if anyone can tell if its a clone \$\endgroup\$ – TheAndyEngineer Mar 1 '17 at 22:31
  • 1
    \$\begingroup\$ The current sense path on the ACS chips is just a couple of mOhms, and the overload current is like 50X the max sense current. It is very strange. It doesn't even have a mode of operation like that, where the output is suppressed. You could order a real one from a supplier like mouser or digikey and replace the IC on your board. \$\endgroup\$ – mkeith Mar 2 '17 at 0:16
  • 1
    \$\begingroup\$ Replaced the IC on the ACS board with a new one from element14 and pleased to say all works as expected, putting this one down to counterfeit IC, thanks everyone \$\endgroup\$ – TheAndyEngineer Mar 8 '17 at 22:50
0
\$\begingroup\$

Unfortunately, time constraints meant I was unable to investigate further, however, I ordered some ACS712 chips from a different supplier and fitted them to the module. After doing that the modules worked fine meaning it must have been manufacturing defective chips.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.