5
\$\begingroup\$

I am trying my hands-on with Kicad recently. I have created an LED astable multi-vibrator circuit in the Eeschema as follows. Schematics

Then I have created a PCB out of it as below. PCB

I wanted to add the two power supply pins on the PCB. So, I used two SolderWirePad_single_0-8mmDrills.

But then I needed to connect these two drill points (+, GND) to the actual tracks of the circuit.

I did this before successfully for the POS(+) terminal encircled in PINK colour.

But now I cannot add a track for the (GND) terminal encircled in RED colour (seems like I am missing something).

Whenever I am adding a track starting either from one of the emitters of the BC548 or from the GND drill pin, the track is not added after the double clicking on the ending terminal. (Please note: I am able to draw the track, but, it seems something is not validating, may be, the connection.)

  • How to get the power supply tracks when there is no connection in the schematic?
  • Is there any better way to handle this?

Thanks in advance.

\$\endgroup\$
1
  • \$\begingroup\$ If you want to highlight your questions, make them italics or even bold.. But please don't shout. Don't use all caps. Its doesn't feel good to answer. \$\endgroup\$
    – User323693
    Mar 5 '17 at 4:32
7
\$\begingroup\$

The power flags aren't placeable parts. To place connectors for power, you should use connector components in the schematic for those connections.

Here's your schematic with power connectors and power flags:

enter image description here

The purple text by the power flags are the names of the footprints I assigned them.

Here's the completed layout:

enter image description here

Note that there aren't any components placed for the power flags although I did have footprints set for them in the schematic.


To repeat a comment I left earlier: DO NOT turn off the design rules check. It is there to help you. When you turn it off, you downgrade KiCAD from an electronics design package to a drawing program that happens to have a library of electronics parts.

You can see this in your own layout:

enter image description here

That white line from R3 to C2 says that the trace you drew to connect those parts isn't really connected at one end. If you make the board as is with that line still in place, you may find that there is a gap in the trace - no connection, circuit doesn't work.

You picked a nice, simple, common circuit to start with.

That's good.

Use this opportunity to learn how your tools can help you. Turning off rules check and forcing a part onto the board from the layout editor worked this time - but you worked against your tools.

Don't do that. Let the program help you, and learn to work with it. It will make things easier in the long run.

\$\endgroup\$
3
\$\begingroup\$

The "+5V" and "GND" symbols you used are really just net labels - they don't represent physical parts.

You have to place connector symbols of some sort to get a pad to connect your tracks to. I have often used a one-pin schematic symbol associated with a footprint containing a single pad to show a wire connection point.

\$\endgroup\$
0
\$\begingroup\$

Okay, I have to uncheck the Design Rules Check (DRC) checkbox in the Preferences>General dialog box.

\$\endgroup\$
1
  • 2
    \$\begingroup\$ DO NOT do this. The design rules check is an important feature of all good layou programs. You need to learn how to live with it, and follow the restrictions it places on your layout. Look into the KiCAD manual. You need to change the net labels on the pins to match the net they should be connected to. I'm on my phone, so I can't look this up in KiCAD itself right now. \$\endgroup\$
    – JRE
    Mar 5 '17 at 7:51
0
\$\begingroup\$

You should post a picture of your schematic too. Pin 1 in that red circle has a No Connect X through it, so you won't be able to connect anything to it and it will just be floating.

EDIT: After having my vision adjusted, I see the schematic now. I don't see any component in the schematic that would associate with those +6V and GND pads? pcbnew is wondering what they represent in the schematic. Add a 2x1 jumper for them in the schematic, then associate them with a single footprint in cvpcb, then generate the netlist and re-read it in pcbnew (you probably know the routine). Or split them and do two 1x1 jumpers. Either way, they have to have a representation in eeschema.

Have you tried switching to OpenGL mode (hit F11 and F9 to get back)? OpenGL mode is a lot better at routing and since it does push and shove routing by default, it will "show" you if you have a clearance issue by routing your trace away from pads.

Also, as to the strange issue of your cap not being connected even though it clearly looks like the trace is connected: Did you drop the cap's pad on top of the trace after you had already routed the trace? The only thing I can think of is that KiCad is just being finicky about your pad placement relative to the track. Try hitting Backspace over the track segment that is connecting the cap. Then go to Preferences, General and set both options for Magnetic Tracks and Magnetic Vias for "Always." This will guarantee that your track is being placed right by snapping to the pad. Then try routing it again.

\$\endgroup\$
2
  • \$\begingroup\$ One of us needs to have an eye examination. I thought I saw a schematic diagram in the question - that's where I copied the one I drew from. \$\endgroup\$
    – JRE
    Mar 5 '17 at 18:44
  • \$\begingroup\$ Huh. It didn't load on my phone earlier. I only could see the PCB. And I thought you drew that based on his PCB. Thanks for the snark though. \$\endgroup\$
    – royalt213
    Mar 6 '17 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.