0
\$\begingroup\$

Tried to change baudrate of the esp8266 with At command "AT+IPR=9600". After reset, blue led on the ESP8266 was constatly on and could not communicate with the device using AT commands.Before changing the baudrate I could communicate with ESP8266 with At commands.After abit of search on the net, decided to flash the device with new firmware.

Downloaded the lastet firmware version: esp8266_nonos_sdk_v2.0.0_16_08_10 from Espressif official website.I Followed intructions according to the readme file in the folder(esp8266_nonos_sdk_v2.0.0_16_08_10). which bin file goes/flashed where. Using nodemcu flasher and it was a success according to the log file of the flasher.The problem am encountering is that I still can`t communicate with the esp8266 with AT commands.using Arduino serial monitor to communicate with the device mentioned.

firmware ver when I bought the chip SDK version: 1.3.0 Build:1.3.0.2

\$\endgroup\$
  • \$\begingroup\$ Have you tried different baud rates with just the AT command? 115200? \$\endgroup\$ – Dejvid_no1 Mar 16 '17 at 19:29
  • \$\begingroup\$ Yes i have tried almost all the baud rates. \$\endgroup\$ – jonny2612 Mar 16 '17 at 19:38
  • \$\begingroup\$ Is this similar to your problem? esp8266.com/viewtopic.php?f=32&t=3841 \$\endgroup\$ – Dejvid_no1 Mar 16 '17 at 21:47
  • \$\begingroup\$ It is not the same as the link you provided. The blue led is on constantly, but when i ground gpio 0 to put the device in flashing mode the blue led goes off as expected. My problem is that even after uploaded the lasted firmware i still can not communicate with the device(ESP8266) using AT commands. \$\endgroup\$ – jonny2612 Mar 17 '17 at 17:27
1
\$\begingroup\$

I've had the same problem and seems that I resolved it. Different ESPs have different memory addresses for the firmware. The AT firmware consists of more parts, as you already mentioned. Mine were these, finally the correct values (bins taken from ESP8266-firmware-at-github):

boot 00000
user 01000
blank FB000
init_data_default FC000
blank 7E000
blank FE000

How to troubleshoot:

1, check if the ESP is booting. Set baud rate at 74880 and reset the ESP. This is the baud rate at which the boot sequence can be observed. SHuold look like this:

ets Jan 8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 612, room 16 
tail 4
chksum 0x12
load 0x3ffe8000, len 788, room 4 
tail 0
chksum 0x50
load 0x3ffe8314, len 264, room 8 
tail 0
chksum 0x4a
csum 0x4a

2nd boot version : 1.1
 SPI Speed : 40MHz
 SPI Mode : QIO
 SPI Flash Size : 8Mbit
jump to run user1


⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮

2, Is the user program portion running?

jump to run user1

This is the part where it says how the code is being run and if it errors out. If you get something similar to this, that's definitely wrong and you have flashed the wrong bin to a wrong memory address and / or used an incompatible firmware:

...
SPI Speed : 40MHz
SPI Mode : QIO
SPI Flash Size : 8Mbit
jump to run usererror user bin flag, flag = 6

3, Check out my struggle -> ESP-01s 8266 brick and revive - hope it helps, there are some more details, including a schematic etc. I have chosen to go the Linux / Python way, but the approach is more or less generic, I think.

\$\endgroup\$
0
\$\begingroup\$

Unfortunately, I encountered this same problem and all I could work out is that I bricked the device. Hopefully, If you are lucky this is not the case for you. Try programming the ESP with some custom Arduino code and see if it takes. Sometimes that may be enough.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.