0
\$\begingroup\$

A while ago I had some trouble with a TPS73633 (see Troubleshooting handsoldered TPS73633 SOT-23 LDO whose output is unexpectedly high) . I didn't get the 3.3v output voltage that I was expecting, whatever I tried. Since I wan't sure whether the error was in my board design or somewhere else, and I wanted to get to the bottom of it, I designed a new board specifically for testing the TPS73633.

My final goal would be to use the TPS73633 to power a ESP8266.

My testing board looks like this:

enter image description here

it follows the "typical application circuit" design in the datasheet (http://www.ti.com/lit/ds/symlink/tps73633-ep.pdf). The board design looks like this:

enter image description here

Unfortunately, I do not get 3.3v out of it when I hook it up to one of these batteries:

enter image description here

At first I thought the problem was that I bought these ldo's cheaply in China, so I bought another batch to see if it woukld make any difference, and then I aven bought some from farnell, so I would be sure I had the real deal, but whatever I tried, I never got a output voltage of 3.3v. What I did get was 2v, 4v and 0.2v:

enter image description here

I even bought a few TPS73733DCQ ldo's, wich are basically the same thing in a SOT-223-6 package, but even those gave me 0.2v as output. So after all this testing I'm a bit lost at why I don't get a simple LDO to do what it should do.

I did all my tests while a load was attached ans with fully charged batteries. I also measured all connections and it doesn't seem like the problem is in my soldering skills.

The only other thing I could think of is that I either soldered at a too high temperature (300 c) or that there's something wrong with these batteries.

Does anyone have a clue what I'm doing wrong here?

Update 19-03

As suggested by peufeu I removed all capacitors. That actually did the trick for most of the ldo's, i finally got 3.3v out of it (except for the Chinese ones from the first batch, I expect them to be counterfeits, they just give a output voltage that is the same as the input voltage).

After that discovery, I started adding capacitors again, since the datasheet suggest doing so, in this diagram:

enter image description here

In my original design I was using capacitors of 1uf, 0.22uf and 0.01uf. To be honest, I don't remember why I chose those values.

In the datasheet I only found this information:

Although an input capacitor is not required for stability, it is good analog design practice to connect a 0.1-µF to 1-µF low ESR capacitor across the input

it doesn't say anything about the value of the other 2 optional capacitors. I tried using a 1uf capacitor for all three capacitors, and that seems to work fine. Is there some standard rule as to what values you would use in a case like this?

\$\endgroup\$
  • 1
    \$\begingroup\$ What is the input voltage? Also, since this LDO can work without caps, try it without caps. If you have a scope, check for oscillations. \$\endgroup\$ – peufeu Mar 18 '17 at 14:06
  • \$\begingroup\$ The input voltage is between 3.7 and 4.3v. As suggested, I tried it without the capacitors, and that did work! see my update in the post. Unfortunately I don't have a scope. \$\endgroup\$ – ErikL Mar 19 '17 at 9:47
  • 1
    \$\begingroup\$ Okay, so the culprit is likely to be an oscillating regulator. Pretty ironic for a "cap free/any cap" regulator, but I guess a small enough cap will make anything oscillate! Also, your GND routing is quite bad... \$\endgroup\$ – peufeu Mar 19 '17 at 10:46
  • \$\begingroup\$ After re soldering with different caps with the same values, I eventually got it working, thanks for your help. I guess I could improve the circuit by adding a ground plane, is that what you mean? \$\endgroup\$ – ErikL Mar 20 '17 at 14:30
  • \$\begingroup\$ Ground plane isn't really necessary, but a nice, straight, thick GND track from IN to OUT would be nice, along with shorter capacitor traces. Also, the regulator sets its output relative to its own GND pin, so PSRR and transient response can be degraded is regulator GND is taken in the wrong spot... \$\endgroup\$ – peufeu Mar 20 '17 at 16:02
1
\$\begingroup\$

post a schematic of your board would be helpful.

I would try a few things:

1) make sure that the layout matches the schematic;

2) make sure that the chip is real;

3) make sure that the battery provides the right voltage output when connected to the board;

4) make sure that the battery is correctly connected to the board;

5) make sure that your meters are accurate;

6) make sure that the chip is soldered on correctly;

7) put a small load to the ldo output;

...

basically, make as few assumptions as you can and start with the things that you are the most sure about.

\$\endgroup\$
  • \$\begingroup\$ thanks for your suggestions. they helped me debugging the problems. 1. Yes 2. I got 2 batches from China, and one from farnell. In the end on eof the batches from china turned out to do nothing at all (input voltage was the same as output voltage) 3. Yes 4. In one case i did it the wrong way, wich resulted in 0.2v 5. It's a very cheap one, prabably should save some money for a better one. 6. I had 2 cased where a resolder resulted in a proper result, guess I have to up my skills on soldering with solder paste. 7. Yes \$\endgroup\$ – ErikL Mar 20 '17 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.