I'm using a 32.768 kHz crystal FC - 12M on a board with STM32L433 in a LQFP48 package. There are two 10pF C0G load capacitors used.

The problem is that on one of the boards (I have two of this revision) the LSE oscillator won't start until I touch it with a scope probe (10x setting, 10M, 16pF). After that touch with the probe, it stabilizes in a second or two and seems to work correctly until I unplug the board.

I've tried with 4.7pF, 10pF, 12pF and 22pF load caps. (the other board that works has 12pF installed).

I've tried cleaning the board with iso alcohol, thinking flux residue might cause this.

I use short traces and ground underneath the oscillator.


Any ideas?

  • 1
    \$\begingroup\$ If on one board it works correctly it's looks like soldering defect. Try to resold capacitors, crystal and MCU pads. \$\endgroup\$
    – Fasset
    Mar 20, 2017 at 6:56
  • \$\begingroup\$ I agree with Fasset, this is probably bad solder joint somwhere (try resolder the crystal) or the crystal might be damaged. \$\endgroup\$
    – MathiasE
    Mar 20, 2017 at 8:08
  • \$\begingroup\$ Murata recommends to use a symmetric layout and no ground plane under oscillators - haven't had much issues so far not following this, but might make a difference. \$\endgroup\$
    – Arsenal
    Mar 20, 2017 at 8:47
  • \$\begingroup\$ Try adding some output series resistance. Maybe 33 ohms. It could be that the output of the STM32L433 isn't low enough resistance to get the required phase shift to start oscillation. \$\endgroup\$
    – Andy aka
    Mar 20, 2017 at 10:06
  • \$\begingroup\$ st.com/content/ccc/resource/technical/document/datasheet/f7/a0/… See AN2867 - Application note - Oscillator design guide for STM8S, STM8A and STM32 microcontrollers \$\endgroup\$ Mar 20, 2017 at 17:39

1 Answer 1


It was a problem with the no-clean flux. After two days the remaining flux residue evaporated and now it's fine on all boards.

A reference to this problem and a high leakage current caused by it can be found in this Application note from TI MSP430™ 32-kHz Crystal Oscillators

  • 1
    \$\begingroup\$ Thank you very much. I had the same problem with ATXMEGA32a4U. I had 4 on the same board, two of them were RTC oscillators which would not start. In my software, the line: "Bitwait Rtc_status.0 , Reset " never passes because the RTC oscillators do not start. Whenever I put a multimeter probe on it, it starts working. I had washed my boards before and I put a capacitor on the crystal pin, but without any result. As I was readig this post, I put an hot air on the MCU pins again and some oil came out. I tested it and it works fine now. \$\endgroup\$ Jun 2, 2019 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.