0
\$\begingroup\$

enter image description here

I see a strange issue while placing the above library part on the PCB file. After placement,the silkscreen and mechanical layer gets an offset .Any suggestion what could be the issue?

\$\endgroup\$
0
\$\begingroup\$

There is a little purple snot at the left hand end of the mechanical region (Just about visible on the screen)....

Mechanical outlines are rectangular bounding boxes so the presence of that little bit of line causes the size of the bounding box to do what you are seeing.

Remove it, save, do an update from libs and things should become more sensible.

This one gets particularly annoying when the object causing the problem is invisible, you end up using the pcb lib inspector and list to track it down and kill it.

I am guessing you have the option for what to put under the mouse set to component centre rather then pin 1, which makes this kind of thing even more aggravating.

\$\endgroup\$
1
  • \$\begingroup\$ Yeah, sometimes that happens to me with rooms, which I turn off by default. \$\endgroup\$ – Joel Wigton Mar 22 '17 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.