0
\$\begingroup\$

I read other answers about scaling problems when printing with Eagle and I don't think my printer is completely at fault.

I ran some tests. I tried printing a PCB (about 8 inches by 4 inches in real size) with the following settings:

  1. Landscape, and letter size paper
  2. Portrait, and A4 size paper
  3. Portrait, and letter size paper

All other printer settings are the same in all tests.

When I printed (I checked the caption option), the sizes are different each time, and I think the sizes are denoted by the letter "f" in the caption.

The caption format printed is as follows:

"XX/XX/XXXX TT:TT:TT f=S.SS /path/to/file.brd"

where XX/XX/XXXX is the current date, TT:TT:TT is the time and f=S.SS which I believe is the scale factor. The S.SS reported 0.83, 0.96 and 0.93 respectively even though I set scale to 1 in software.

Is there some simple workaround to this? could I somehow force F to be 1?

\$\endgroup\$
  • \$\begingroup\$ Which version of Eagle, and what OS? I am using V7.7 on Windows, and when the scale factor is set to '1' it is not shown in the caption (ie. it just prints "XX/XX/XXXX TT:TT:TT \path\to\file.brd") \$\endgroup\$ – Bruce Abbott Mar 26 '17 at 3:36
  • \$\begingroup\$ Eagle 4.16r2 for Linux. I know its old, but it routed my boards and I use it extensively. Maybe I need a patch then? \$\endgroup\$ – user143136 Mar 26 '17 at 3:57
  • \$\begingroup\$ It may help if you share GUI's "print setup" and/or "print" screens (windows). I use versions 4 and 5 (Win), there's special field to put scale factor into, and then Eagle splits image into several pages if needed. Never had such print issues... \$\endgroup\$ – Anonymous Mar 26 '17 at 8:48
1
\$\begingroup\$

I actually found a solution that works even though its a crazy one.

First, I had to reset user preferences. As I am using linux, I had to delete .eaglerc file and restart eagle and reload my board.

Then in the printing settings, I needed to make sure the page limit was set to zero instead of one, and also I had to match up my paper sizes in my printer driver to that in eagle. That way, if the page is too large, the board will span onto two pages instead of shrink itself to fit one page. Luckily I wasted little ink thanks to an installed pdf file generation printer on my computer. I also tested my theory with a real printer and it seems to work (at least for normal paper).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy