6
\$\begingroup\$

In Altium, the location of the designator and the comment of the component on the schematics are moved to a default position every time I update the component from the library. Is there a way to fix a default location for each component or disable change of the location when updating the component?

\$\endgroup\$
2
\$\begingroup\$

If all you're doing is changing the graphical representation or the footprints then this method works perfectly. If you want to change the base parameters or which library the component is coming from then you're not going to be able to do it. However, as changing the graphical symbol and the footprints is the most common change, this should usually work.

Don't update from the library. Update from the schematic with Tools->Update From Libraries.

Then uncheck the option to update parameters: enter image description here

The main problem is when the parameters get updated, because that's when the position gets reset.

You can uncheck the box for selected components only or just select the ones you want and update that way. It then creates a proper ECO instead of forcing changes you don't want.

For instance if I for some reason wanted to change where the circle was on my test point from top to bottom like this:

enter image description here enter image description here

And then did an update from the library, my schematic would look like this:

enter image description here

But, if I save the library then go back to the schematic and update using Tools->Update From Libraries with the above options, I get this:

enter image description here

It works the same way for updating the footprints in the library and then updating from the schematic. Use caution though, updating the footprints will reset which footprint is selected for use in the PCB by default. You can uncheck the option in the generated ECO.


EDIT: Sorry you actually can do a full replace too, just use the other option in the Update From Libraries dialog. For some reason I remember this not working correctly for me, perhaps erasing schematic specific parameters, but at a glance it appears to work. Either way should work.

enter image description here

Edit 2: Yes, I believe the "Preserve Parameter Visibility" option is new in one of the more recent releases.

|improve this answer|||||
\$\endgroup\$
2
\$\begingroup\$

I believe this can be done from within the schematic library. When creating or editing the component symbol in the library editor, go to Tools --> Document Options (or shortcut T-D). The following window will appear:

enter image description here

Make sure the "Always Show Comment/Designator" box is checked. This will allow you to see and manually move the designator position.

[image to come -- imgur appears to be down]

This is only half of the solution, though. This is how you can set your own position, but the next part is to tell the software to use your default position instead of its own. In order to do this, back in the library editor, double-click the designator (or whatever text you want to fix), or right-click it and open the "Properties" window. In the panel that opens, uncheck the "Autoposition" box:

[image to come -- imgur appears to be down]

This will tell Altium not to move the designator from where it is placed in the library when the part is added or updated from the library.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ Very nice note about editing the library designator position. However, unchecking the Autoposition option didn't seem to work for me. \$\endgroup\$ – Samuel Jun 16 '17 at 20:03
  • \$\begingroup\$ @Samuel You also updated the position of the designator in the library editor? I just tried this on several library components and it worked every time. Also, it doesn't automatically update if you already have the symbol placed, you have to update from the library \$\endgroup\$ – DerStrom8 Jun 16 '17 at 20:04
  • 1
    \$\begingroup\$ I just tried setting a custom position of the designator in the library and unchecked autoposition for both it and the existing one in the schematic. It resets the position when updating from the library. \$\endgroup\$ – Samuel Jun 16 '17 at 20:07
  • \$\begingroup\$ Hmm, wonder if it's a setting somewhere. What does it do if you try to pull it in fresh from the library, rather than updating from the library? \$\endgroup\$ – DerStrom8 Jun 16 '17 at 20:11
  • \$\begingroup\$ If I do the Update From Library method I described below it doesn't change the position. Still gets messed up when pushing changes from the library. \$\endgroup\$ – Samuel Jun 16 '17 at 20:14
1
\$\begingroup\$

I have tried this in the past. As far as I am aware there's no way to force it to hold locations in AD11 through 16 (going to start 17 next week).

Some people say you could use the schematic editor to position them differently from the start (While in Library Editor: Tools > Document Options; Check "Always Show Comment/Designator"), but in my experience when you rotate or flip parts or all of the component this will result in an even bigger mess, if not initially then certainly on update.

Until, finally, enough people complain to Altium about this, it's likely you'll have to live with it. But all of this is just a "I tried once and after an afternoon just gave up", so who knows, there may be a way after all.


Even disable Auto-Position is useless, it works, until an update from library over-writes it. Even with Auto-position disabled from the library, the bloody thing still puts them back, neatly with auto-position turned off.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ Added an answer that might work for you as well. \$\endgroup\$ – Samuel Jun 16 '17 at 19:32
  • \$\begingroup\$ @Samuel I think my answer may actually be simpler and more in-line with what the OP is looking for \$\endgroup\$ – DerStrom8 Jun 16 '17 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.