1
\$\begingroup\$

I'm building a simple motor shield for Arduino based on the L293D bridge driver. I'm doing some tests on a breadboard everything is fine as long as I drive the motor at full throttle with DC inputs (enable HIGH, inputs HIGH and LOW to spin CW/CCW).

I can regulate the speed applying a TTL PWM signal on the enable pin with a function generator. It works fine but using the oscilloscope I can see the TTL signal drop from 5 to 3,5/4 Volts as soon as I connect it to the L293D enable pin, even with no motor attached. Why is that happening? Is that supposed to be? I thought an enable pin should draw no current and cause no voltage drop.

I tried replacing the IC and the function generator but I still get that behavior. I get no voltage drop using a regular PS and 5V DC.

What's wrong?

\$\endgroup\$
  • \$\begingroup\$ Regardless of the specific question, please don't use the L293 or L298 in new designs, bipolar bridges like that are horribly lossy and antiquated, see the numerous existing threads here on that subject. \$\endgroup\$ – Chris Stratton Apr 3 '17 at 23:02
  • \$\begingroup\$ I know I'm using a dinosaur but there's a reason for that. \$\endgroup\$ – dodod Apr 4 '17 at 5:18
  • \$\begingroup\$ Do you have a schematic? And what are the function generators you tested your configuration with? \$\endgroup\$ – HatimB Apr 4 '17 at 11:02
2
\$\begingroup\$

Well, my fault! I made a stupid mistake and forgot to wire the logic supply Vcc1. I didn't notice it because the pin wasn't unconnected (decoupling capacitor) and the motor did spin anyway (that's unexpected!). I did measure a current draw of 20-30 mA that caused the voltage drop and double checked the circuit. With Vcc1 in place there's no current at all.

So... that's it. Should I delete this question?

\$\endgroup\$
  • 2
    \$\begingroup\$ No, don't delete neither the question nor the answer. It might help someone in the future. \$\endgroup\$ – m.Alin Apr 4 '17 at 12:42
  • 1
    \$\begingroup\$ exactly the same happened to me. I also forgot Vcc1 and by extensive search over problems with l293d I came here and immediately noticed my mistake. Thanks to dodod and to @m.Alin. \$\endgroup\$ – NilsB Nov 5 '18 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.