0
\$\begingroup\$

I am using sim800c gsm module.

It is showing some weird problems that am not able to figure out.

The at commands are working fine.

The problem is that, the module stops working after inserting the sim card. After the power button is pressed, it gives the following messages:

RDY, +CFUN: 1, +CPIN: READY, Call Ready. After this, the module stops working, the led stops blinking. If i don't insert sim card this won't happen.

The power supply is proper 4.1 v 3A, even i tested with 4V battery there also it shows the same problem. So I don't think this is power supply problem.

I tried with different sim cards and got the same result. this is the circuit diagramenter image description here

\$\endgroup\$
  • \$\begingroup\$ So it stops responding to serial commands, but works fine if you don't insert the SIM? \$\endgroup\$ – pjc50 Apr 7 '17 at 19:07
  • \$\begingroup\$ correct. The led also stops blinking. One more thing I have noticed. If I select CBAND= DCS_MODE , it will not stop working but it doesn't get registered to network. I tried all CBAND modes. It stops working for all the other possible modes apart form DCs_mode. \$\endgroup\$ – Mukesh Apr 7 '17 at 19:14
3
\$\begingroup\$

It only tries to register when it has a SIM.

To register, it must transmit.

Either the supply voltage drops when it transmits and causes the processor to hang, or the RF is getting somewhere and causing problems.

I don't see a bypass capacitor on your power supply in, though there may be one on the module.

You may also need a large capacitor on Vbat to help with the current peaks when the module transmits.

\$\endgroup\$
  • 1
    \$\begingroup\$ Thank you very much.You were right. I used external 4 v power supply and it had capacitors. But it was long away from Vbat pin since I connected using the wires. I soldered 1000uf capacitor near to V bat pin and it solved the issue. \$\endgroup\$ – Mukesh Apr 7 '17 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.