3
\$\begingroup\$

My Altera Quartus builds show this warning...

Warning (18236): Number of processors has not been specified which may cause overloading on shared machines.  Set the global assignment NUM_PARALLEL_PROCESSORS in your QSF to an appropriate value for best performance.

How do I suppress this warning?

\$\endgroup\$
6
\$\begingroup\$

Add this tcl expression...

set_global_assignment -name NUM_PARALLEL_PROCESSORS 4

... to either assignment_defaults.qdf or the .qsf file. Both should be in the project's directory. The .qdf file may need to be created.

\$\endgroup\$
  • 1
    \$\begingroup\$ Probably worth marking this as accepted to stop the system bumping it back to the homepage. \$\endgroup\$ – Tom Carpenter Jun 30 '17 at 16:12
  • \$\begingroup\$ There is also an option to use all available processors, which also gets rid of the warning, and adjusts the setting to whatever machine the compile runs on. \$\endgroup\$ – Simon Richter Oct 9 '18 at 18:40
  • \$\begingroup\$ @SimonRichter, what name and value would be used? \$\endgroup\$ – JimFred Oct 10 '18 at 19:21
  • \$\begingroup\$ @JimFred set_global_assignment -name NUM_PARALLEL_PROCESSORS ALL \$\endgroup\$ – matli Mar 13 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.