0
\$\begingroup\$

I have issues with getting ESP8266 to work for me. The current state is that when I connect power I get this output on 74880 bitrate:

ets Jan 8 2013,rst cause:2, boot mode:(2,6)

Fatal exception (0): epc1=0x4010006a, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000

I tried esptool.py with nodemcu firmware, I tried ESP Flash Download Tool according to instruction from here: https://www.allaboutcircuits.com/projects/update-the-firmware-in-your-esp8266-wi-fi-module/ - still the effect is the same.

One thing to note is that I also have issues with getting the upload to work, but once it starts it always succeeds. Later, however, it does not seems to have any effect.

I saw many people having similar issue, but reflashing for me does not help. Any further ideas? What do these numbers mean?

UPDATE: I have just noticed that when restarting the module multiple times from time to time I get this output:

 ets Jan  8 2013,rst cause:1, boot mode:(3,0)

load 0x40100000, len 816, room 16 
tail 0
chksum 0x8d
load 0x3ffe8000, len 788, room 8 
tail 12
chksum 0xcf
ho 0 tail 12 room 4
load 0x3ffe8314, len 288, room 12 
tail 4
chksum 0xcf
csum 0xcf

2nd boot version : 1.2
  SPI Speed      : 26.7MHz
  SPI Mode       : DIO
  SPI Flash Size : 8Mbit
jump to run user1

Any idea what might cause different behaviour from time to time? Note that I would expect +OK next, but it never happens.

\$\endgroup\$
1
\$\begingroup\$

Inconsistent behavior at startup is typically indicative of a bad power supply. The most likely issues are either:

  • The part is drawing more current during startup than your power supply can reliably provide.

  • The voltage of your power supply is rising too slowly, or is otherwise unstable during startup.

Note that the 3.3V regulator built into many FTDI parts can only provide 50 mA. This is what most FTDI breakouts use for their 3.3V output -- 50 mA is nowhere near enough current for an ESP8266, so you will see malfunctions if you try using that. Use a separate power regulator, or ideally a separate power supply entirely!

\$\endgroup\$
  • \$\begingroup\$ Now I used 5V from FTDI board and routed it through LP2950CZ-3.3 stabilizer and still no change. I also added 3300uF capacitor and use reset pin to reset the chip (so that the voltage is stable during powerup). I know that ideally I would use oscilloscope to find out whether the power supply is stable, but I don't have one - is there anything I could check to find out whether my setup is ok? \$\endgroup\$ – Tomasz Grobelny May 11 '17 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.