0
\$\begingroup\$

After applying a ground plan on the PCB, eagle tells me that the two resistor's ground are not connected to each other. This problem is recurrent for several points on the circuit. The problem remain after clicking on the "ratsnet" button.

Here is a screenshot with the two resistors and the property of the polygone used for the ground plan.

enter image description here

Does someone have an explanation? This section of the PCB doesn't bother me much because it's obviously connected. But, this issue becomes annoying when it's getting complex..

\$\endgroup\$
2
  • \$\begingroup\$ It is difficult answer since we don't have a full screen shot of the circuit. But I would guess that you have a PCB trace that is 'cutting the ground plane in half'. Thus you have two grounds that aren't connected. Please let us know if this is the case. A1_RED might be the trace that is separating the grounds. \$\endgroup\$
    – Izzo
    Commented May 28, 2017 at 18:32
  • \$\begingroup\$ @Izzo I restarted Eagle and it's working fine now... I don't get it \$\endgroup\$
    – M.Ferru
    Commented May 28, 2017 at 18:40

1 Answer 1

1
\$\begingroup\$

Your polygon settings are wrong.

You have currently set the "Isolate" parameter to 0, which means that the polygon should have 0 clearance between it any everything else (i.e. it will just short everything out). Eagle shows some small clearance regardless, but rest assured there will be no clearance in the Gerber files.

Try setting a sensible isolation value (e.g. 6 mil) and see what happens. In Eagle 6.x the airwires would go away and the only indication of the problem would be errors in the DRC and Gerbers. I don't know if this is something they have changed in the newer versions (you must be using either 7.x or 8.x to see the net names on traces).

Additionally, do you have more than one polygon overlapping? If so, make sure each has a different "Rank" value, otherwise you may get strange errors, both in DRC and in how it displays.

\$\endgroup\$
1
  • \$\begingroup\$ I've restarted Eagle and it's work fine now. For some reasons the display had some issue.. Thanks for the remark, I'll check this out \$\endgroup\$
    – M.Ferru
    Commented May 28, 2017 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.