0
\$\begingroup\$

I bought this RS232-TTL converter https://www.digikey.com/product-detail/en/seeed-technology-co-ltd/101990008/1597-1306-ND/5487765

and I'm using this along with an Arduino Mega 2560

I'm feeding the Arduino using this dc-dc converter directly to a 5[V] pin (i know this is not recommended and using a dc-dc is advised) https://www.digikey.com/products/en?keywords=pyb10q24s5u

The DC-DC is feeded by a 12[V] - 12[A] DC power supply.

The same DC-DC is used to feed the rs232-ttl module


Testing configuration:

-2400b 8 bits 1 sb np.

-PC > USB cable > Arduino(usb powered) > RS232-TTL module(powered by the 
Arduino)>RS232-USB>PC(com8)

->sometimes it works:

Vcc = 5[V]
V+ = 8 [V]
V- = -8 [V]
C1 and C2 oscillate.
communication** works 

-> and sometimes it doesn´t.

Vcc= 5[V]
V+= 4[V]
V-=0.6 [V]
C1 and C2 not oscillating.
Communication** not working.

EDIT: if i send a character from the PC, it starts to work, which is not a desired behavior.

EDIT2: same behavior with the Arduino out of the picture)


Now, using the intended connections .

(usb cable not connected)
PowerSource>DC-DC>Arduino(powered by dc-dc)>RS232 module (nothing 
connected)

Symptoms:

Vcc= 5 [V]
V+= 4 [V]
V-=0.6 [V]
C1 and C2 not oscillating.
Communication not working
heats

Same connections, using loopback:

Vcc= 5 [V]
V+= 4 [V]
V-=0.6 [V]
C1 and C2 not oscillating.
-Rx at 3 [V]
-Tx at 3 [V]

Same connections, connected to pc

Vcc= 5 [V]
V+= 4 [V]
V-=0.6 [V]
C1 and C2 not oscillating.
Rx out: at 3 [V], when a signal is sent from PC, it goes from 1 [V] to 
4[V] then goes back to 3 [V]
Tx out: nothing

i've been trying everything, i bought 6 RS232 modules and tried 3 so far, all of them have the same symptoms

EDIT: well, the RS232-TTL works IF a signal comes from the RS232 side first (ie:PC or Modem), if the TTL part does Tx first (ie: Arduino), the max3232 will heat and it becomes unusable, it seems to be a problem with the low power mode. And that is all, no solutions, just a work around.

\$\endgroup\$
  • \$\begingroup\$ Is the chip actually a MAX3232? I recall some chips have "power down" options that may be causing you issues. \$\endgroup\$ – Spehro Pefhany Jun 5 '17 at 15:15
  • \$\begingroup\$ the chip says: max3232 ese +1513 i'll take a look for the power down option \$\endgroup\$ – FelBraSil Jun 5 '17 at 15:30
  • 1
    \$\begingroup\$ Get the arduino out of the picture and verify that the converter itself works by looping back the logic level output to input. \$\endgroup\$ – Chris Stratton Jun 5 '17 at 15:39
  • \$\begingroup\$ without the arduino, a character was needed from the PC in order to make the C's oscilate \$\endgroup\$ – FelBraSil Jun 5 '17 at 16:33
  • \$\begingroup\$ the datasheet talks about a 1uA energy save mode, but it doesn't Tx from the arduino unless i send something from the PC, and only if i power it from the USB. \$\endgroup\$ – FelBraSil Jun 5 '17 at 19:53
1
\$\begingroup\$

So it was a bad design in the end, the unused Tx can't be left floating, yet all of the modules i tried had the unused Tx floating (MAX232 has 2 channels, but the modules use just 1 channel) .

If they are floating, they will act as antennas if there are RF signals, and will latch the IC, thus heating in the process.

Used the TI galvanic isolated TTL-RS232 transceiver instead, made a PCB with it and now the communication works flawlessly. http://www.ti.com/lit/ug/tidu298/tidu298.pdf

In this place it's explained why it is bad design, and it's about the same problem i had, just in a slightly different situation http://www.edaboard.com/thread352767.html

Extra advice: if you are planning to transmit data through RF and you will be placing the modem relatively close to your transmitting TTL device, by all means try to get a modem that has an interface at TTL levels, adding a RS232 interface in the middle also adds a possible point of failure, plus it costs more.

\$\endgroup\$
  • 1
    \$\begingroup\$ If this answers the question then you can accept it as the answer (even though you wrote it yourself). Your posts are very sloppily written and this will affect your credibility and the likelihood of getting a good response. \$\endgroup\$ – Transistor Jan 24 '18 at 18:15
  • \$\begingroup\$ i am not the only one with the problem and it's even documented as a bug, there is not a solution for this on the internet and this answer is just what solved things in my case, as there are other solutions that didn't work for me, given by the same people who requested help, just like me. i would like to learn to make my posts less sloppy which is probably true, but without feedback it's hard to get better. \$\endgroup\$ – FelBraSil Jan 26 '18 at 16:55
  • 1
    \$\begingroup\$ That's fine. Start with proper capitalisation of words ("I"), proper nouns ("Arduino"), initialisations ("RS232", "TTL") and punctuation. Note that SI units named after a person are lowercase when spelled out and uppercase in their symbol form. e.g. volt = V, ampere = A, watt = W, ohm = Ω, kelvin = K, etc. Without them the posts are difficult to read and give a poor impression of the author. \$\endgroup\$ – Transistor Jan 26 '18 at 17:13
  • \$\begingroup\$ Thanks for the nice advice, and sorry for the poor writing, this will help me a lot. \$\endgroup\$ – FelBraSil Jan 26 '18 at 17:18
  • \$\begingroup\$ It is very common practice to ground unused pins, especially on transceiver inputs (or at least tie them to a valid logic level). The datasheet for that MAX3232 even instructs you to do this for the inputs in sections 8.3.2 and 9.2.2 \$\endgroup\$ – evildemonic Jan 26 '18 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.